summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-16 18:32:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-17 16:43:04 +0000
commitfd17edbd00f1583eb9e1912ab269dd4dc2631a6f (patch)
tree655ef8867f37649c56427bac126e3ac8f9cd906a
parentc0e4ca3c7841028a658f21c11619228022d425b4 (diff)
downloadopenembedded-core-contrib-fd17edbd00f1583eb9e1912ab269dd4dc2631a6f.tar.gz
classes/python_pep517: consolidate stub do_configure
As PEP517 doesn't have an explicit configure step, we can stub out the do_configure task once instead of the calling classes doing it. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/python_flit_core.bbclass6
-rw-r--r--meta/classes/python_pep517.bbclass8
-rw-r--r--meta/classes/python_poetry_core.bbclass6
-rw-r--r--meta/classes/setuptools_build_meta.bbclass6
4 files changed, 7 insertions, 19 deletions
diff --git a/meta/classes/python_flit_core.bbclass b/meta/classes/python_flit_core.bbclass
index eef361bb1b..96652aa204 100644
--- a/meta/classes/python_flit_core.bbclass
+++ b/meta/classes/python_flit_core.bbclass
@@ -3,9 +3,3 @@ inherit python_pep517 python3native python3-dir setuptools3-base
DEPENDS += "python3 python3-flit-core-native"
PEP517_BUILD_API = "flit_core.buildapi"
-
-python_flit_core_do_configure () {
- :
-}
-
-EXPORT_FUNCTIONS do_configure
diff --git a/meta/classes/python_pep517.bbclass b/meta/classes/python_pep517.bbclass
index 73bcf9ba07..34ffdc9c0d 100644
--- a/meta/classes/python_pep517.bbclass
+++ b/meta/classes/python_pep517.bbclass
@@ -22,6 +22,12 @@ PEP517_INSTALL_PYTHON:class-native = "nativepython3"
# pypa/installer option to control the bytecode compilation
INSTALL_WHEEL_COMPILE_BYTECODE ?= "--compile-bytecode=0"
+# PEP517 doesn't have a specific configure step, so set an empty do_configure to avoid
+# running base_do_configure.
+python_pep517_do_configure () {
+ :
+}
+
# When we have Python 3.11 we can parse pyproject.toml to determine the build
# API entry point directly
python_pep517_do_compile () {
@@ -47,4 +53,4 @@ python_pep517_do_bootstrap_install () {
unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PEP517_WHEEL_PATH}/*.whl
}
-EXPORT_FUNCTIONS do_compile do_install
+EXPORT_FUNCTIONS do_configure do_compile do_install
diff --git a/meta/classes/python_poetry_core.bbclass b/meta/classes/python_poetry_core.bbclass
index 3fecb6c6bb..577663b8f1 100644
--- a/meta/classes/python_poetry_core.bbclass
+++ b/meta/classes/python_poetry_core.bbclass
@@ -3,9 +3,3 @@ inherit python_pep517 python3native setuptools3-base
DEPENDS += "python3-poetry-core-native"
PEP517_BUILD_API = "poetry.core.masonry.api"
-
-python_poetry_core_do_configure () {
- :
-}
-
-EXPORT_FUNCTIONS do_configure
diff --git a/meta/classes/setuptools_build_meta.bbclass b/meta/classes/setuptools_build_meta.bbclass
index 62b037363d..b2bba35a0b 100644
--- a/meta/classes/setuptools_build_meta.bbclass
+++ b/meta/classes/setuptools_build_meta.bbclass
@@ -3,9 +3,3 @@ inherit setuptools3-base python_pep517
DEPENDS += "python3-setuptools-native python3-wheel-native"
PEP517_BUILD_API = "setuptools.build_meta"
-
-setuptools_build_meta_do_configure () {
- :
-}
-
-EXPORT_FUNCTIONS do_configure