summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2018-06-05 15:58:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-15 11:09:40 +0100
commitea618e061fa190e4ae647da6466d074b49940395 (patch)
tree6295de0487718d80776f41549ac061171bd9caa1
parent306435507c4790ec44f30cd3c7fa7d340b441ec4 (diff)
downloadopenembedded-core-contrib-ea618e061fa190e4ae647da6466d074b49940395.tar.gz
nettle: do the multilib_header magic for nettle-stdint.h and version.h
add multilib support for this receipe, or it will conflicts in mutlilib setting Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-support/nettle/nettle_3.4.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-support/nettle/nettle_3.4.bb b/meta/recipes-support/nettle/nettle_3.4.bb
index 7a3cc654c8..ca8450ea99 100644
--- a/meta/recipes-support/nettle/nettle_3.4.bb
+++ b/meta/recipes-support/nettle/nettle_3.4.bb
@@ -25,7 +25,7 @@ SRC_URI[sha256sum] = "ae7a42df026550b85daca8389b6a60ba6313b0567f374392e54918588a
UPSTREAM_CHECK_REGEX = "nettle-(?P<pver>\d+(\.\d+)+)\.tar"
-inherit autotools ptest
+inherit autotools ptest multilib_header
EXTRA_AUTORECONF += "--exclude=aclocal"
@@ -35,6 +35,10 @@ do_compile_ptest() {
oe_runmake buildtest
}
+do_install_append() {
+ oe_multilib_header nettle/nettle-stdint.h nettle/version.h
+}
+
do_install_ptest() {
install -d ${D}${PTEST_PATH}/testsuite/
install ${S}/testsuite/gold-bug.txt ${D}${PTEST_PATH}/testsuite/