summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-03-16 18:32:41 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-17 16:43:04 +0000
commitd42664a5b5fb460185be996428dbaba6bb81ec3f (patch)
treeaabae88d543f5bf2ca9c479d6bab5aaf9e5bd0ca
parente38afe528f25038f5adb7a7a94a1e007011696ee (diff)
downloadopenembedded-core-contrib-d42664a5b5fb460185be996428dbaba6bb81ec3f.tar.gz
classes/python_pep517: add more comments
Remove mention of prebuilt wheels, this is for the full PEP517 build process and recipes that want to install prebuilt wheels can use pypa/installer directly. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/classes/python_pep517.bbclass9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta/classes/python_pep517.bbclass b/meta/classes/python_pep517.bbclass
index 83c6dcb5c7..73bcf9ba07 100644
--- a/meta/classes/python_pep517.bbclass
+++ b/meta/classes/python_pep517.bbclass
@@ -1,5 +1,8 @@
# Common infrastructure for Python packages that use PEP-517 compliant packaging.
# https://www.python.org/dev/peps/pep-0517/
+#
+# This class will build a wheel in do_compile, and use pypa/installer to install
+# it in do_install.
DEPENDS:append = " python3-installer-native"
@@ -9,14 +12,14 @@ PEP517_SOURCE_PATH ?= "${S}"
# The PEP517 build API entry point
PEP517_BUILD_API ?= "unset"
-# The directory where wheels should be written too. Build classes
-# will ideally [cleandirs] this but we don't do that here in case
-# a recipe wants to install prebuilt wheels.
+# The directory where wheels will be written
PEP517_WHEEL_PATH ?= "${WORKDIR}/dist"
+# The interpreter to use for installed scripts
PEP517_INSTALL_PYTHON = "python3"
PEP517_INSTALL_PYTHON:class-native = "nativepython3"
+# pypa/installer option to control the bytecode compilation
INSTALL_WHEEL_COMPILE_BYTECODE ?= "--compile-bytecode=0"
# When we have Python 3.11 we can parse pyproject.toml to determine the build