aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-03-16 22:09:43 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-16 22:11:15 +0000
commit10dc69467677a4ce2a26aa670bbb9c1d7d783a0e (patch)
tree03cfb907b99f67bdf8ef42a6821f4faa9e55d179
parente022b27d189c1dcc7b3baea2b99dba8d724e6e2b (diff)
downloadopenembedded-core-contrib-10dc69467677a4ce2a26aa670bbb9c1d7d783a0e.zip
openembedded-core-contrib-10dc69467677a4ce2a26aa670bbb9c1d7d783a0e.tar.gz
openembedded-core-contrib-10dc69467677a4ce2a26aa670bbb9c1d7d783a0e.tar.bz2
packagegroup-core-lsb: avoid rebuilding when changing layer config
It's regrettable that code in here is referring to BBFILE_COLLECTIONS, but it is, and the result is that this packagegroup will rebuild simply by adding or removing a layer which may be completely unrelated to whether you've got meta-qt4 or not. Add BBFILE_COLLECTIONS to vardepsexclude for the function to avoid this. (This was flagged up when testing the new yocto-compat-layer script - it understandably but undesirably reports it as a change caused by a layer). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index 3aedf6b..a156bcb 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -225,6 +225,8 @@ def get_libqt4(d):
'libraries. Its intended use is for passing LSB tests as Qt4 is ' \
'a requirement for LSB.')
return ''
+# We don't want this to rebuild every time you change your layer config
+get_libqt4[vardepsexclude] += "BBFILE_COLLECTIONS"
SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \