summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-14 15:00:07 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-16 22:21:31 +0000
commitf781e2a70ce1086c49e0c3d5ac61b7bf5bd79a9c (patch)
treeb028e9fa76de57cccb51f753484052a5f50fd28c
parent3d6bf58c7080c1cacf3ed1f270ff5acf4858c790 (diff)
downloadopenembedded-core-contrib-f781e2a70ce1086c49e0c3d5ac61b7bf5bd79a9c.tar.gz
valgrind: partially fix ptests
Unfortunately the ptests assume that $S=$B, and also require the presence of original source code. There are still some failures left which require additional investigation. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.15.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
index aedaab27b3..6a3834cfdc 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.15.0.bb
@@ -64,7 +64,8 @@ COMPATIBLE_HOST_linux-gnun32 = 'null'
# Disable for powerpc64 with musl
COMPATIBLE_HOST_libc-musl_powerpc64 = 'null'
-inherit autotools ptest multilib_header
+# brokenseip is unfortunately required by ptests to pass
+inherit autotools-brokensep ptest multilib_header
EXTRA_OECONF = "--enable-tls --without-mpicc"
EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
@@ -116,7 +117,7 @@ RDEPENDS_${PN}-ptest += " bash coreutils file \
gdb libgomp \
perl \
perl-module-getopt-long perl-module-file-basename perl-module-file-glob \
- procps sed ${PN}-dbg"
+ procps sed ${PN}-dbg ${PN}-src"
RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
# One of the tests contains a bogus interpreter path on purpose.