summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-04 23:14:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-06 15:12:34 +0100
commitee585ced8e48bca508c03ce71741bbcd672ee80d (patch)
tree0aca03fdcd550a4c93ce438f9fa653d0a813433e
parent6cd2cf6525bcb241b3a2538e559fcef2a2084a7e (diff)
downloadopenembedded-core-contrib-ee585ced8e48bca508c03ce71741bbcd672ee80d.tar.gz
dhcp: Use -fcommon compiler option
This ensures -fcommon is still used when compiler defaults to -fno-common in gcc10 and clang11 Fixes dhcp-4.4.2/server/mdb.c:70: multiple definition of `dhcp_type_host'; dhcpd-omapi.o:/usr/src/debug/dhcp/4.4.2-r0/dhcp-4.4.2/server/omapi.c:50: first defined here Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-connectivity/dhcp/dhcp_4.4.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/dhcp/dhcp_4.4.2.bb b/meta/recipes-connectivity/dhcp/dhcp_4.4.2.bb
index b56a204821..cf4af82609 100644
--- a/meta/recipes-connectivity/dhcp/dhcp_4.4.2.bb
+++ b/meta/recipes-connectivity/dhcp/dhcp_4.4.2.bb
@@ -19,3 +19,5 @@ LDFLAGS_append = " -pthread"
PACKAGECONFIG ?= ""
PACKAGECONFIG[bind-httpstats] = "--with-libxml2,--without-libxml2,libxml2"
+
+CFLAGS += "-fcommon"