aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-03-15 18:54:58 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-20 09:30:17 +0000
commit5bfba3d09cfabb3a1895dcf9921801df318d804c (patch)
tree220b70cdaee423ccd138c1b6a173268ec7ad4ec6
parent022866aa0ea6d7a8963d05bb10881e8d97bdf442 (diff)
downloadopenembedded-core-contrib-5bfba3d09cfabb3a1895dcf9921801df318d804c.tar.gz
python3-native: fix build races in 'make regen-all'
Python 2.x and target Python 3.x do not have this issue. [YOCTO #12596] Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.4.bb b/meta/recipes-devtools/python/python3-native_3.5.4.bb
index c8252539a9..a5dedb7aa7 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.4.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.4.bb
@@ -64,6 +64,8 @@ do_configure_append() {
# Regenerate all of the generated files
# This ensures that pgen and friends get created during the compile phase
do_compile_prepend() {
+ # Has to be done ahead of other regen- targets due to https://bugs.python.org/issue33080
+ oe_runmake regen-importlib
oe_runmake regen-all
}