aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-08-04 14:14:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-20 22:31:13 +0000
commit3328211afdef8ffb00dd4dff1143959d5412b075 (patch)
tree4903b2b0ed8c09605baf9c546eac47fa0617d83a
parentc47b54aeae5daabb458d6f7118a16257021c1822 (diff)
downloadopenembedded-core-contrib-3328211afdef8ffb00dd4dff1143959d5412b075.tar.gz
python: fix RDEPENDS on several recipes, due to non-existent packages
The packaging has been altered slightly so ensure the dependencies are all still valid. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/recipes-core/libxml/libxml2_2.9.7.bb2
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb2
-rw-r--r--meta/recipes-devtools/dnf/dnf_2.7.5.bb26
-rw-r--r--meta/recipes-devtools/gdb/gdb-cross-canadian.inc4
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.3.5.bb2
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.13.3.bb2
-rw-r--r--meta/recipes-devtools/python/python-async.inc2
-rw-r--r--meta/recipes-devtools/python/python-git.inc7
-rw-r--r--meta/recipes-devtools/python/python-gitdb.inc1
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.1.bb1
-rw-r--r--meta/recipes-devtools/python/python-setuptools.inc3
-rw-r--r--meta/recipes-devtools/python/python-smmap.inc1
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb1
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.26.1.bb2
-rw-r--r--meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb2
-rw-r--r--meta/recipes-graphics/piglit/piglit_git.bb4
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb2
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_1.1.bb2
18 files changed, 37 insertions, 29 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.9.7.bb b/meta/recipes-core/libxml/libxml2_2.9.7.bb
index 85bfecae88..2fb90a68a8 100644
--- a/meta/recipes-core/libxml/libxml2_2.9.7.bb
+++ b/meta/recipes-core/libxml/libxml2_2.9.7.bb
@@ -40,7 +40,7 @@ inherit autotools pkgconfig binconfig-disabled ptest
inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
-RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-argparse python3-logging python3-shell python3-signal python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
+RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
index a3101351ee..c047be1e85 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.8.bb
@@ -139,7 +139,7 @@ do_install () {
PACKAGES =+ "pybootchartgui"
FILES_pybootchartgui += "${PYTHON_SITEPACKAGES_DIR}/pybootchartgui ${bindir}/pybootchartgui"
-RDEPENDS_pybootchartgui = "python3-pycairo python3-compression python3-image python3-textutils python3-shell python3-compression python3-codecs"
+RDEPENDS_pybootchartgui = "python3-pycairo python3-compression python3-image python3-shell python3-compression python3-codecs"
RDEPENDS_${PN}_class-target += "${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'sysvinit-pidof', 'procps', d)}"
RDEPENDS_${PN}_class-target += "lsb"
DEPENDS_append_class-native = " python3-pycairo-native"
diff --git a/meta/recipes-devtools/dnf/dnf_2.7.5.bb b/meta/recipes-devtools/dnf/dnf_2.7.5.bb
index fbd3bd4571..b88ddb445a 100644
--- a/meta/recipes-devtools/dnf/dnf_2.7.5.bb
+++ b/meta/recipes-devtools/dnf/dnf_2.7.5.bb
@@ -25,8 +25,30 @@ DEPENDS += "libdnf librepo libcomps python3-iniparse"
EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
BBCLASSEXTEND = "native nativesdk"
-RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient python3-email python3-threading python3-distutils librepo python3-shell python3-subprocess libcomps libdnf python3-sqlite3 python3-compression python3-rpm python3-iniparse python3-json python3-importlib python3-curses python3-argparse python3-misc python3-gpg"
-# Recommend gnupg so that GPG signature check on repository metadata is possible
+
+RDEPENDS_${PN}_class-target += " \
+ python3-core \
+ python3-codecs \
+ python3-netclient \
+ python3-email \
+ python3-threading \
+ python3-distutils \
+ python3-logging \
+ python3-fcntl \
+ librepo \
+ python3-shell \
+ libcomps \
+ libdnf \
+ python3-sqlite3 \
+ python3-compression \
+ python3-rpm \
+ python3-iniparse \
+ python3-json \
+ python3-curses \
+ python3-misc \
+ python3-gpg \
+ "
+
RRECOMMENDS_${PN}_class-target += "gnupg"
# Create a symlink called 'dnf' as 'make install' does not do it, but
diff --git a/meta/recipes-devtools/gdb/gdb-cross-canadian.inc b/meta/recipes-devtools/gdb/gdb-cross-canadian.inc
index 3ff1989538..4fc6747d9d 100644
--- a/meta/recipes-devtools/gdb/gdb-cross-canadian.inc
+++ b/meta/recipes-devtools/gdb/gdb-cross-canadian.inc
@@ -13,9 +13,9 @@ GDBPROPREFIX = "--program-prefix='${TARGET_PREFIX}'"
# Overrides PACKAGECONFIG variables in gdb-common.inc
PACKAGECONFIG ??= "python readline"
PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,nativesdk-python3, \
- nativesdk-python3-core nativesdk-python3-lang nativesdk-python3-re \
+ nativesdk-python3-core \
nativesdk-python3-codecs nativesdk-python3-netclient \
- nativesdk-python3-importlib"
+ "
PACKAGECONFIG[readline] = "--with-system-readline,--without-system-readline,nativesdk-readline"
SSTATE_DUPWHITELIST += "${STAGING_DATADIR}/gdb"
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.5.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.5.bb
index 514ba7912a..e9ba9de094 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.5.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.5.bb
@@ -20,7 +20,7 @@ SRC_URI[sha256sum] = "7f4b08912e26a3f4f6f423f3b4e7157a73b1f3a7483fc59b216d1a80b5
TARGET_CC_ARCH += "${LDFLAGS}"
# For native builds we use the host Python
-PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-subprocess python3-pickle python3-compression python3-textutils python3-stringold"
+PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
PYTHONRDEPS_class-native = ""
PACKAGECONFIG = "python update-alternatives"
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.13.3.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.13.3.bb
index 42b2a18a5b..277c21f9da 100644
--- a/meta/recipes-devtools/python-numpy/python3-numpy_1.13.3.bb
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.13.3.bb
@@ -102,11 +102,9 @@ RDEPENDS_${PN} = "python3-unittest \
python3-pydoc \
python3-pkgutil \
python3-email \
- python3-subprocess \
python3-compression \
python3-ctypes \
python3-threading \
- python3-textutils \
"
RDEPENDS_${PN}_class-native = ""
diff --git a/meta/recipes-devtools/python/python-async.inc b/meta/recipes-devtools/python/python-async.inc
index 0874667e0c..6664ab013c 100644
--- a/meta/recipes-devtools/python/python-async.inc
+++ b/meta/recipes-devtools/python/python-async.inc
@@ -9,6 +9,6 @@ inherit pypi
SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b"
SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051"
-RDEPENDS_${PN} += "${PYTHON_PN}-threading ${PYTHON_PN}-lang"
+RDEPENDS_${PN} += "${PYTHON_PN}-threading"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python-git.inc b/meta/recipes-devtools/python/python-git.inc
index bef08eb74e..8d37693960 100644
--- a/meta/recipes-devtools/python/python-git.inc
+++ b/meta/recipes-devtools/python/python-git.inc
@@ -17,19 +17,14 @@ SRC_URI[sha256sum] = "ad61bc25deadb535b047684d06f3654c001d9415e1971e51c9c20f5b51
DEPENDS = "${PYTHON_PN}-gitdb"
-RDEPENDS_${PN} += "${PYTHON_PN}-argparse \
+RDEPENDS_${PN} += " \
${PYTHON_PN}-datetime \
- ${PYTHON_PN}-enum \
${PYTHON_PN}-gitdb \
${PYTHON_PN}-io \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-logging \
${PYTHON_PN}-math \
${PYTHON_PN}-netclient \
- ${PYTHON_PN}-re \
- ${PYTHON_PN}-shell \
${PYTHON_PN}-stringold \
- ${PYTHON_PN}-subprocess \
${PYTHON_PN}-unittest \
${PYTHON_PN}-unixadmin \
git \
diff --git a/meta/recipes-devtools/python/python-gitdb.inc b/meta/recipes-devtools/python/python-gitdb.inc
index b32b869a02..2d5292e5d4 100644
--- a/meta/recipes-devtools/python/python-gitdb.inc
+++ b/meta/recipes-devtools/python/python-gitdb.inc
@@ -17,7 +17,6 @@ RDEPENDS_${PN} += "${PYTHON_PN}-async \
${PYTHON_PN}-compression \
${PYTHON_PN}-crypt \
${PYTHON_PN}-io \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-mmap \
${PYTHON_PN}-shell \
${PYTHON_PN}-smmap \
diff --git a/meta/recipes-devtools/python/python-scons_3.0.1.bb b/meta/recipes-devtools/python/python-scons_3.0.1.bb
index 2f75b08d25..d5084b2d16 100644
--- a/meta/recipes-devtools/python/python-scons_3.0.1.bb
+++ b/meta/recipes-devtools/python/python-scons_3.0.1.bb
@@ -18,5 +18,4 @@ RDEPENDS_${PN} = "\
python-subprocess \
python-shell \
python-pprint \
- python-importlib \
"
diff --git a/meta/recipes-devtools/python/python-setuptools.inc b/meta/recipes-devtools/python/python-setuptools.inc
index d6eeeba2e3..54b7c300e0 100644
--- a/meta/recipes-devtools/python/python-setuptools.inc
+++ b/meta/recipes-devtools/python/python-setuptools.inc
@@ -30,15 +30,12 @@ RDEPENDS_${PN} = "\
${PYTHON_PN}-distutils \
${PYTHON_PN}-email \
${PYTHON_PN}-html \
- ${PYTHON_PN}-importlib \
${PYTHON_PN}-netserver \
${PYTHON_PN}-numbers \
${PYTHON_PN}-pkgutil \
${PYTHON_PN}-plistlib \
${PYTHON_PN}-shell \
- ${PYTHON_PN}-subprocess \
${PYTHON_PN}-stringold \
- ${PYTHON_PN}-textutils \
${PYTHON_PN}-threading \
${PYTHON_PN}-unittest \
${PYTHON_PN}-xml \
diff --git a/meta/recipes-devtools/python/python-smmap.inc b/meta/recipes-devtools/python/python-smmap.inc
index 32438350c1..55aa516e0a 100644
--- a/meta/recipes-devtools/python/python-smmap.inc
+++ b/meta/recipes-devtools/python/python-smmap.inc
@@ -13,7 +13,6 @@ SRC_URI[md5sum] = "d7932d5ace206bf4ae15198cf36fb6ab"
SRC_URI[sha256sum] = "0e2b62b497bd5f0afebc002eda4d90df9d209c30ef257e8673c90a6b5c119d62"
RDEPENDS_${PN} += "${PYTHON_PN}-codecs \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-mmap \
"
BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index 4ce13da410..cd849eb08e 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -37,7 +37,6 @@ do_install_append() {
RDEPENDS_${PN} = "\
python3-compile \
python3-io \
- python3-enum \
python3-html \
python3-json \
python3-netserver \
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
index 0405b44f17..91f2d53d78 100644
--- a/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
+++ b/meta/recipes-devtools/python/python3-pygobject_3.26.1.bb
@@ -24,7 +24,7 @@ PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wa
# we don't link against python3-pycairo -> RDEPENDS
PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
-RDEPENDS_${PN} += "python3-setuptools python3-importlib"
+RDEPENDS_${PN} += "python3-setuptools"
BBCLASSEXTEND = "native"
PACKAGECONFIG_class-native = ""
diff --git a/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
index 943ca5f89d..1a9ad5cc2b 100644
--- a/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
+++ b/meta/recipes-devtools/qemu/nativesdk-qemu-helper_1.0.bb
@@ -1,6 +1,6 @@
SUMMARY = "Qemu helper scripts"
LICENSE = "GPLv2"
-RDEPENDS_${PN} = "nativesdk-qemu nativesdk-python3-subprocess \
+RDEPENDS_${PN} = "nativesdk-qemu \
nativesdk-python3-shell nativesdk-python3-fcntl \
"
diff --git a/meta/recipes-graphics/piglit/piglit_git.bb b/meta/recipes-graphics/piglit/piglit_git.bb
index 06c5021eb7..2839f1d285 100644
--- a/meta/recipes-graphics/piglit/piglit_git.bb
+++ b/meta/recipes-graphics/piglit/piglit_git.bb
@@ -44,9 +44,9 @@ do_configure_prepend() {
OECMAKE_TARGET_INSTALL = "install/strip"
RDEPENDS_${PN} = "waffle python3 python3-mako python3-json \
- python3-subprocess python3-misc python3-importlib \
+ python3-misc \
python3-unixadmin python3-xml python3-multiprocessing \
- python3-six python3-shell python3-io python3-argparse \
+ python3-six python3-shell python3-io \
python3-netserver mesa-demos bash \
"
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
index 012b2dd0a7..5f61c4ecdd 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_1.1.bb
@@ -22,5 +22,5 @@ do_install() {
}
FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"
-RDEPENDS_${PN} = "python3 python3-subprocess python3-textutils"
+RDEPENDS_${PN} = "python3-core "
RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
diff --git a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
index 4336c50d63..496f04fdba 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_1.1.bb
@@ -26,6 +26,6 @@ do_install_ptest() {
cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
}
-RDEPENDS_${PN}-ptest += " stress python3 python3-subprocess python3-multiprocessing python3-datetime python3-re python3-lang python3-misc"
+RDEPENDS_${PN}-ptest += " stress python3 python3-multiprocessing python3-datetime python3-misc"
FILES_${PN} += "${prefix}/src/backfire"