summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-04-04 17:11:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-05 11:46:34 +0100
commitff074f495dd4bb637618f790dd30e51e542cd30a (patch)
treef4aa61dc9970e25e80ce7d08a867b50d3985e93c
parent660fdaa95858485b1caa779f1137a933c1f5d5f6 (diff)
downloadopenembedded-core-contrib-ff074f495dd4bb637618f790dd30e51e542cd30a.tar.gz
busybox: sysctl: ignore EIO of stable_secret below /proc/sys/net/ipv6/conf
Avoid confusing messages caused by EIO on reading /proc/sys/net/ipv6/conf/*/stable_secret if those are not set yet. Make it behave the same as procps(>=3.3.13). Fixes: $ sysctl -a | grep ipv6.conf | grep stable_secret sysctl: error reading key 'net.ipv6.conf.all.stable_secret': Input/output error sysctl: error reading key 'net.ipv6.conf.default.stable_secret': Input/output error sysctl: error reading key 'net.ipv6.conf.eth0.stable_secret': Input/output error sysctl: error reading key 'net.ipv6.conf.lo.stable_secret': Input/output error Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/busybox/busybox/0001-sysctl-ignore-EIO-of-stable_secret-below-proc-sys-ne.patch40
-rw-r--r--meta/recipes-core/busybox/busybox_1.31.1.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/0001-sysctl-ignore-EIO-of-stable_secret-below-proc-sys-ne.patch b/meta/recipes-core/busybox/busybox/0001-sysctl-ignore-EIO-of-stable_secret-below-proc-sys-ne.patch
new file mode 100644
index 0000000000..9f58eaef67
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/0001-sysctl-ignore-EIO-of-stable_secret-below-proc-sys-ne.patch
@@ -0,0 +1,40 @@
+From 3bee0460d74bad88eca6592e63ca926961b43b67 Mon Sep 17 00:00:00 2001
+From: Yi Zhao <yi.zhao@windriver.com>
+Date: Fri, 6 Mar 2020 16:09:26 +0800
+Subject: [PATCH] sysctl: ignore EIO of stable_secret below
+ /proc/sys/net/ipv6/conf
+
+Avoid confusing messages caused by EIO on reading
+/proc/sys/net/ipv6/conf/*/stable_secret if those are not set yet.
+Make it behave the same as procps(>=3.3.13).
+
+Upstream-Status: Submitted [busybox@busybox.net mailing list]
+
+Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
+---
+ procps/sysctl.c | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/procps/sysctl.c b/procps/sysctl.c
+index 6d77185ca..42c51cc91 100644
+--- a/procps/sysctl.c
++++ b/procps/sysctl.c
+@@ -202,7 +202,14 @@ static int sysctl_act_on_setting(char *setting)
+ value = cptr = xmalloc_read(fd, NULL);
+ close(fd);
+ if (value == NULL) {
+- bb_perror_msg("error reading key '%s'", outname);
++ switch (errno) {
++ case EIO:
++ /* Ignore stable_secret below /proc/sys/net/ipv6/conf */
++ break;
++ default:
++ bb_perror_msg("error reading key '%s'", outname);
++ break;
++ }
+ retval = EXIT_FAILURE;
+ goto end;
+ }
+--
+2.17.1
+
diff --git a/meta/recipes-core/busybox/busybox_1.31.1.bb b/meta/recipes-core/busybox/busybox_1.31.1.bb
index ec5b580442..2bb1d59ba7 100644
--- a/meta/recipes-core/busybox/busybox_1.31.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.31.1.bb
@@ -47,6 +47,7 @@ SRC_URI = "https://busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://0003-runsv-Use-64-prefix-syscall-if-we-have-to.patch \
file://0001-Remove-syscall-wrappers-around-clock_gettime-closes-.patch \
file://0001-Remove-stime-function-calls.patch \
+ file://0001-sysctl-ignore-EIO-of-stable_secret-below-proc-sys-ne.patch \
"
SRC_URI_append_libc-musl = " file://musl.cfg "