summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2020-04-01 10:32:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-02 00:51:45 +0100
commit57b4745cca8d486c1f20b8f01f4a25cb59c4b968 (patch)
tree5b866f744689e7403201e592a84f99054e8020c7
parent03e498cd7e35902202579d404f4aad5c92664f18 (diff)
downloadopenembedded-core-contrib-57b4745cca8d486c1f20b8f01f4a25cb59c4b968.tar.gz
perf: fix compile error when rebuilding
Fix error like: Makefile.perf:597: recipe for target 'intel_x86_64-wrs-linux/perf/1.0-r9/perf-1.0/perf-in.o] Error 2 Makefile.perf:220: recipe for target 'sub-make' failed make[1]: *** [sub-make] Error 2 Makefile:69: recipe for target 'all' failed make: *** [all] Error 2 during rebuilding, when kernel version changed, some source files also maybe changed. It could happened that the source under ${S} messed up with some already dropped files and also new files. Fix by clean the ${S} before copy source files. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index e005eb082b..c4b7b77e99 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -147,6 +147,7 @@ python copy_perf_source_from_kernel() {
src_dir = d.getVar("STAGING_KERNEL_DIR")
dest_dir = d.getVar("S")
bb.utils.mkdirhier(dest_dir)
+ bb.utils.prunedir(dest_dir)
for s in sources:
src = oe.path.join(src_dir, s)
dest = oe.path.join(dest_dir, s)