summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-26 21:10:42 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2017-11-26 21:18:17 -0800
commite35842932714ebd67d5e0f52fcb7a88bc7caffce (patch)
treeb90a711ab75937867ac45997b401237b9e7d1cfa
parent16e81962f73a1616d96ca84a7268d66e24b5328d (diff)
downloadopenembedded-core-contrib-e35842932714ebd67d5e0f52fcb7a88bc7caffce.tar.gz
python3-pip: use pypi.bbclass
* Simplify recipe using pypi.bbclass Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-pip_9.0.1.bb14
1 files changed, 4 insertions, 10 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
index a6dd72df3b..b56862c245 100644
--- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb
@@ -1,22 +1,15 @@
SUMMARY = "The PyPA recommended tool for installing Python packages"
-sHOMEPAGEsss = "https://pypi.python.org/pypi/pip"
+HOMEPAGE = "https://pypi.python.org/pypi/pip"
SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
-SRCNAME = "pip"
DEPENDS += "python3 python3-setuptools-native"
-SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
SRC_URI[md5sum] = "35f01da33009719497f01a4ba69d63c9"
SRC_URI[sha256sum] = "09f243e1a7b461f654c26a725fa373211bb7ff17a9300058b205c61658ca940d"
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit distutils3
+inherit pypi distutils3
DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
@@ -33,7 +26,7 @@ do_install_append() {
rm ${D}/${bindir}/pip
# Installed eggs need to be passed directly to the interpreter via a pth file
- echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
+ echo "./${PYPI_PACKAGE}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${PYPI_PACKAGE}-${PV}.pth
# Make sure we use /usr/bin/env python3
for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do
@@ -46,6 +39,7 @@ RDEPENDS_${PN} = "\
python3-io \
python3-html \
python3-json \
+ python3-netclient \
python3-netserver \
python3-setuptools \
python3-unixadmin \