summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2017-11-08 15:17:08 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-21 13:06:45 +0000
commit62113c4fbb7b4c2c2f4859cb5679274b3f60fddb (patch)
tree53c82a1fdc9583e8277c040165fbb98cbbf03722
parent8afaa56313c5fe55b6fa70eabca123bda4c30f41 (diff)
downloadopenembedded-core-contrib-62113c4fbb7b4c2c2f4859cb5679274b3f60fddb.tar.gz
bitbake: bitbake-layers: show-recipes: fix help to mention -i supports multiple classes
The -i option supports more than one class, but the help didn't mention that. (Bitbake rev: 1060955c4aa2ef66cdb4f0549f9bd8c1c332673c) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--bitbake/lib/bblayers/query.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/bitbake/lib/bblayers/query.py b/bitbake/lib/bblayers/query.py
index efd22cb456..9294dfa884 100644
--- a/bitbake/lib/bblayers/query.py
+++ b/bitbake/lib/bblayers/query.py
@@ -490,7 +490,7 @@ NOTE: .bbappend files can impact the dependencies.
parser_show_recipes = self.add_command(sp, 'show-recipes', self.do_show_recipes)
parser_show_recipes.add_argument('-f', '--filenames', help='instead of the default formatting, list filenames of higher priority recipes with the ones they overlay indented underneath', action='store_true')
parser_show_recipes.add_argument('-m', '--multiple', help='only list where multiple recipes (in the same layer or different layers) exist for the same recipe name', action='store_true')
- parser_show_recipes.add_argument('-i', '--inherits', help='only list recipes that inherit the named class', metavar='CLASS', default='')
+ parser_show_recipes.add_argument('-i', '--inherits', help='only list recipes that inherit the named class(es) - separate multiple classes using , (without spaces)', metavar='CLASS', default='')
parser_show_recipes.add_argument('pnspec', nargs='*', help='optional recipe name specification (wildcards allowed, enclose in quotes to avoid shell expansion)')
parser_show_appends = self.add_command(sp, 'show-appends', self.do_show_appends)