aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-05 08:36:02 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-06 10:36:25 +0100
commita6e62aae8f83696755828631e5ff67a579a6462f (patch)
treef83e2eec820e5e5a04e7dfebbe8093d1078d92de
parentda989c32feb76a4f768b6ab99d3cd023bc2bd5b1 (diff)
downloadopenembedded-core-contrib-a6e62aae8f83696755828631e5ff67a579a6462f.tar.gz
opkg-keyrings: do not use 'exit 1' to postpone to first boot
Since `229f4e9 package.bbclass: add support for pkg_postinst_ontarget()' applied in oe-core, use pkg_postinst_ontarget to run postinst at first boot. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb12
1 files changed, 2 insertions, 10 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
index 18d6abdded..a20e316a3d 100644
--- a/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
+++ b/meta/recipes-devtools/opkg/opkg-keyrings_1.0.bb
@@ -35,14 +35,6 @@ FILES_${PN} = "${datadir}/opkg/keyrings"
# We need 'opkg-key' to run the postinst script
RDEPENDS_${PN} = "opkg"
-pkg_postinst_${PN} () {
-#! /bin/sh
-set -e
-
-if [ x"$D" = "x" ]; then
- # On target
- opkg-key populate
-else
- exit 1
-fi
+pkg_postinst_ontarget_${PN} () {
+opkg-key populate
}