summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 15:54:31 -0800
committerTim Orling <timothy.t.orling@linux.intel.com>2020-11-27 16:20:27 -0800
commit9602d7c191ff5a7cff555bf1a2debd93ae8e27e0 (patch)
tree75cf413afe9f889f0e95f963083dd6dbf53cf194
parent919562bd4a5d7ac1161ffce1b20c22f3010c052a (diff)
downloadopenembedded-core-contrib-9602d7c191ff5a7cff555bf1a2debd93ae8e27e0.tar.gz
python3-toml: move from meta-python
Python Library for Tom's Obvious, Minimimal Language * Part of the dependency chain for pytest Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python3-toml_0.10.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-toml_0.10.2.bb b/meta/recipes-devtools/python/python3-toml_0.10.2.bb
new file mode 100644
index 0000000000..b46eba6fd1
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-toml_0.10.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
+HOMEPAGE = "https://github.com/uiri/toml"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16c77b2b1050d2f03cb9c2ed0edaf4f0"
+
+SRC_URI[sha256sum] = "b3bda1d108d5dd99f4a20d24d9c348e91c4db7ab1b749200bded2f839ccbe68f"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+"