summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSinan Kaya <okaya@kernel.org>2020-11-18 22:54:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-24 10:27:38 +0000
commit0fd0b5cc27e3ef72bc00f593b0730b7fca5d0450 (patch)
treeef276e047ab891c2ca9d2b5123b176b181a42bc8
parent65410c5ff4f9c34758d1e2270132c631166e7d1a (diff)
downloadopenembedded-core-contrib-0fd0b5cc27e3ef72bc00f593b0730b7fca5d0450.tar.gz
volatile-binds: add /srv to mount and install
We are installing a service to volatile mount /srv directory but we are not creating it on the target. Signed-off-by: Sinan Kaya <okaya@kernel.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/volatile-binds/volatile-binds.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/volatile-binds/volatile-binds.bb b/meta/recipes-core/volatile-binds/volatile-binds.bb
index b273293e9a..3c8b18291e 100644
--- a/meta/recipes-core/volatile-binds/volatile-binds.bb
+++ b/meta/recipes-core/volatile-binds/volatile-binds.bb
@@ -35,7 +35,7 @@ def volatile_systemd_services(d):
SYSTEMD_SERVICE_${PN} = "${@volatile_systemd_services(d)}"
-FILES_${PN} += "${systemd_unitdir}/system/*.service"
+FILES_${PN} += "${systemd_unitdir}/system/*.service ${servicedir}"
do_compile () {
while read spec mountpoint; do
@@ -64,6 +64,7 @@ do_compile[dirs] = "${WORKDIR}"
do_install () {
install -d ${D}${base_sbindir}
+ install -d ${D}${servicedir}
install -m 0755 mount-copybind ${D}${base_sbindir}/
install -d ${D}${systemd_unitdir}/system