summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-03-26 21:53:44 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-28 10:24:40 +0000
commit732a9c83e946580607af3478cdc765d6541e3f64 (patch)
tree4e243abb5e74f415d846d1d317571fa38ea62cda
parentff617d478cb3213deb23cf0124c04beab4d4ecc8 (diff)
downloadopenembedded-core-contrib-732a9c83e946580607af3478cdc765d6541e3f64.tar.gz
gdk-pixbuf: remove a test that sporadically fails without reproducibility
The test is randomly modifying file data and some of these random modifications cause OOM failures. There is no way to preserve and repeat what was modified, so the test needs to re-engineered to do proper fuzzing. See here for details: https://gitlab.gnome.org/GNOME/gdk-pixbuf/-/issues/146 Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
index 699c4ecd0b..d0df5015a5 100644
--- a/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
+++ b/meta/recipes-gnome/gdk-pixbuf/gdk-pixbuf_2.40.0.bb
@@ -99,6 +99,11 @@ do_install_append() {
}
+# Remove a bad fuzzing attempt that sporadically fails without a way to reproduce
+do_install_ptest() {
+ rm ${D}/${datadir}/installed-tests/gdk-pixbuf/pixbuf-randomly-modified.test
+}
+
do_install_append_class-native() {
find ${D}${libdir} -name "libpixbufloader-*.la" -exec rm \{\} \;