summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-03-24 19:05:00 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-03-24 23:07:55 +0000
commit8ee272e6fdbc65097a3aa3e2456598dd089793eb (patch)
tree17c9f091d232f2b3cdce2404ccd82779b5b940e3
parent43ec35f7cc4f222ad91efdd56f8eea901db52def (diff)
downloadopenembedded-core-contrib-8ee272e6fdbc65097a3aa3e2456598dd089793eb.tar.gz
linux-yocto/5.4: fix kernel selftests
Khem reported that kernel selftests are failing after some of the recent -stable udpates, and identified the followig commits to solve the issues: 4cd12df48b83 selftest/bpf: Use CHECK macro instead of RET_IF 84591c1cb409 Revert "selftests/bpf: Fix perf_buffer test on systems w/ offline CPUs" 844b959f96bd Revert "selftests/bpf: Skip perf hw events test if the setup disabled it" Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb6
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.4.bb20
3 files changed, 15 insertions, 15 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
index 5bdd2f629a..9d237ee32f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "b6eb513c50e6de3746287c4f17058a81d1be613c"
-SRCREV_meta ?= "ccf845f650255696bcd41c4004abf8adba212d5d"
+SRCREV_machine ?= "a069c47171c8b2510401dba1922b49b294c19b0e"
+SRCREV_meta ?= "d40bf6ad14acc6d84d5c9a8e2c794ce37ffa16ff"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA}"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
index 0850725383..02beca0097 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.4.bb
@@ -15,9 +15,9 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine_qemuarm ?= "8f0a54b42e11bee3bf552ae6a04f7ec2267f4dd3"
-SRCREV_machine ?= "45760a7e1301894b3ffd4d1bd76684c99fbff6f7"
-SRCREV_meta ?= "ccf845f650255696bcd41c4004abf8adba212d5d"
+SRCREV_machine_qemuarm ?= "84a0aabc9db1eba2fbfcbd80b3c538cd73f0b03c"
+SRCREV_machine ?= "4cd12df48b83cef9cc7d6b80b128afbf68746718"
+SRCREV_meta ?= "d40bf6ad14acc6d84d5c9a8e2c794ce37ffa16ff"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.4.bb b/meta/recipes-kernel/linux/linux-yocto_5.4.bb
index 98e4accc74..8bad042528 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.4.bb
@@ -12,16 +12,16 @@ KBRANCH_qemux86 ?= "v5.4/standard/base"
KBRANCH_qemux86-64 ?= "v5.4/standard/base"
KBRANCH_qemumips64 ?= "v5.4/standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "e0b9db4dd28cfccc6b0cffd2da6cde7c8d760bdd"
-SRCREV_machine_qemuarm64 ?= "45760a7e1301894b3ffd4d1bd76684c99fbff6f7"
-SRCREV_machine_qemumips ?= "84c43062449817e61dd8e331f49821c65aa23967"
-SRCREV_machine_qemuppc ?= "45760a7e1301894b3ffd4d1bd76684c99fbff6f7"
-SRCREV_machine_qemuriscv64 ?= "45760a7e1301894b3ffd4d1bd76684c99fbff6f7"
-SRCREV_machine_qemux86 ?= "45760a7e1301894b3ffd4d1bd76684c99fbff6f7"
-SRCREV_machine_qemux86-64 ?= "45760a7e1301894b3ffd4d1bd76684c99fbff6f7"
-SRCREV_machine_qemumips64 ?= "08ac7d212e539ed2d17c6714d97b019e48e1fe1c"
-SRCREV_machine ?= "45760a7e1301894b3ffd4d1bd76684c99fbff6f7"
-SRCREV_meta ?= "ccf845f650255696bcd41c4004abf8adba212d5d"
+SRCREV_machine_qemuarm ?= "f4bf0307957258b20048e704ff3683437d7b0373"
+SRCREV_machine_qemuarm64 ?= "4cd12df48b83cef9cc7d6b80b128afbf68746718"
+SRCREV_machine_qemumips ?= "06bdb6af393b84e2c1a6f34b67bf4af36b9331e3"
+SRCREV_machine_qemuppc ?= "4cd12df48b83cef9cc7d6b80b128afbf68746718"
+SRCREV_machine_qemuriscv64 ?= "4cd12df48b83cef9cc7d6b80b128afbf68746718"
+SRCREV_machine_qemux86 ?= "4cd12df48b83cef9cc7d6b80b128afbf68746718"
+SRCREV_machine_qemux86-64 ?= "4cd12df48b83cef9cc7d6b80b128afbf68746718"
+SRCREV_machine_qemumips64 ?= "958ee61d50f664b413f368a7573918a18a00d4ac"
+SRCREV_machine ?= "4cd12df48b83cef9cc7d6b80b128afbf68746718"
+SRCREV_meta ?= "d40bf6ad14acc6d84d5c9a8e2c794ce37ffa16ff"
# remap qemuarm to qemuarma15 for the 5.4 kernel
# KMACHINE_qemuarm ?= "qemuarma15"