aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2020-03-27 19:11:45 -0700
committerTim Orling <timothy.t.orling@linux.intel.com>2020-03-30 19:16:23 +0000
commit3fb7b8a1575e1f360196da294e74657ebffc3446 (patch)
tree0dc78ba66910b3425936745eaa7a2d2bb5d5b088
parent55993465ef9560eb1966d5756cde2b240f5e6fa0 (diff)
downloadopenembedded-core-contrib-3fb7b8a1575e1f360196da294e74657ebffc3446.tar.gz
openembedded-core-contrib-3fb7b8a1575e1f360196da294e74657ebffc3446.tar.bz2
openembedded-core-contrib-3fb7b8a1575e1f360196da294e74657ebffc3446.zip
sanity.bbclass: recommend using install-buildtools
For old tar versions (1.24 and 1.28), recommned using scripts/install-buildtools Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
-rw-r--r--meta/classes/sanity.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index cca5cdad170..0cf955a3414 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -533,9 +533,9 @@ def check_tar_version(sanity_data):
return "Unable to execute tar --version, exit code %d\n%s\n" % (e.returncode, e.output)
version = result.split()[3]
if LooseVersion(version) < LooseVersion("1.24"):
- return "Your version of tar is older than 1.24 and has bugs which will break builds. Please install a newer version of tar (1.28+).\n"
+ return "Your version of tar is older than 1.24 and has bugs which will break builds. Please install a newer version of tar (1.28+). You could use the project's buildtools-tarball from our last release or use scripts/install-buildtools\n"
if LooseVersion(version) < LooseVersion("1.28"):
- return "Your version of tar is older than 1.28 and does not have the support needed to enable reproducible builds. Please install a newer version of tar (you could use the projects buildtools-tarball from our last release).\n"
+ return "Your version of tar is older than 1.28 and does not have the support needed to enable reproducible builds. Please install a newer version of tar (you could use the projects buildtools-tarball from our last release or use scripts/install-buildtools).\n"
return None
# We use git parameters and functionality only found in 1.7.8 or later