summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-01-14 11:53:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-14 11:48:59 +0000
commitfa7020c040189ae904625b5c60c8a7e79dc1145e (patch)
treec83efd1b77b99727529601a6f1280c7933458b14
parentb9d780c7eeda0fefb13edde8bdba4f1d91e7823c (diff)
downloadopenembedded-core-contrib-fa7020c040189ae904625b5c60c8a7e79dc1145e.tar.gz
perl: fix yet another race failure
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl-sanity/files/0001-Also-build-dynaloader-separately-as-race-failures-ha.patch31
-rw-r--r--meta/recipes-devtools/perl-sanity/perl_5.28.1.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl-sanity/files/0001-Also-build-dynaloader-separately-as-race-failures-ha.patch b/meta/recipes-devtools/perl-sanity/files/0001-Also-build-dynaloader-separately-as-race-failures-ha.patch
new file mode 100644
index 0000000000..15678b83ba
--- /dev/null
+++ b/meta/recipes-devtools/perl-sanity/files/0001-Also-build-dynaloader-separately-as-race-failures-ha.patch
@@ -0,0 +1,31 @@
+From 9c68cdd1a89f9b944edc804d7c5d000c45de7b85 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Mon, 14 Jan 2019 11:45:20 +0100
+Subject: [PATCH] Also build dynaloader separately as race failures have been
+ observed in Yocto.
+
+Upstream-Status: Submitted [https://github.com/arsv/perl-cross/issues/72]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 7846406..cd8d75f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -74,10 +74,13 @@ $(CROSSPATCHED): %.applied: %.patch
+ # Force full patching before any building starts. Als, force early building
+ # of miniperl -- not really necessary, but makes the build process more logical.
+ # No reason to try CC if HOSTCC fails.
++#
++# Dynaloader is also built separately as race failures have been observed.
+ all:
+ $(MAKE) crosspatch
+ $(MAKE) miniperl$X
+- $(MAKE) dynaloader perl$x nonxs_ext utilities extensions pods
++ $(MAKE) dynaloader
++ $(MAKE) perl$x nonxs_ext utilities extensions pods
+
+ config.h: config.sh config_h.SH
+ CONFIG_H=$@ CONFIG_SH=$< ./config_h.SH
diff --git a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
index 4ce158f4f8..0df821d446 100644
--- a/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
+++ b/meta/recipes-devtools/perl-sanity/perl_5.28.1.bb
@@ -21,6 +21,7 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \
file://0001-configure_path.sh-do-not-hardcode-prefix-lib-as-libr.patch \
file://fix-race-failures.patch \
file://fix-race-failures-2.patch \
+ file://0001-Also-build-dynaloader-separately-as-race-failures-ha.patch \
"
SRC_URI[perl.md5sum] = "838198c43d4f39d7af797e2f59c2bee5"