summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Bergin <peter@berginkonsult.se>2020-09-15 21:33:05 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-16 14:01:51 +0100
commitc65eb4c38b61509ad38da19b986e0f06923f0cea (patch)
tree09158017968683840a655e74589e2128e87f1e24
parent431a7dfc6c1c86ead3e636d42e2bf1f1f906588c (diff)
downloadopenembedded-core-contrib-c65eb4c38b61509ad38da19b986e0f06923f0cea.tar.gz
systemd: avoid failing if no udev rules provided
In the case when no udev rules are provided by the recipe the do_install step of systemd is failing with: install: cannot stat '<WORKDIR>/*.rules': No such file or directory By default the systemd recipe provides touchscreen.rules but in the case this is unwanted on target the install step fails. This solution is dynamic and search for *.rules files in $WORKDIR. If found they are installed. Signed-off-by: Peter Bergin <peter@berginkonsult.se> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd_246.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_246.2.bb b/meta/recipes-core/systemd/systemd_246.2.bb
index 238cd4741f..af10e4212b 100644
--- a/meta/recipes-core/systemd/systemd_246.2.bb
+++ b/meta/recipes-core/systemd/systemd_246.2.bb
@@ -232,7 +232,9 @@ do_install() {
install -d ${D}${sysconfdir}/udev/rules.d/
install -d ${D}${sysconfdir}/tmpfiles.d
- install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
+ for rule in $(find ${WORKDIR} -maxdepth 1 -type f -name "*.rules"); do
+ install -m 0644 $rule ${D}${sysconfdir}/udev/rules.d/
+ done
install -m 0644 ${WORKDIR}/00-create-volatile.conf ${D}${sysconfdir}/tmpfiles.d/