summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-11-24 09:08:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-25 21:53:44 +0000
commit717e538e70f78d79ba7cec2797024af0dc91aeb0 (patch)
tree759680af9ebf8e0ae6edf1037089a1bd1428bd47
parentf1b1eaf63cd0a762f149d2fed9cbef98eb7f4977 (diff)
downloadopenembedded-core-contrib-717e538e70f78d79ba7cec2797024af0dc91aeb0.tar.gz
python3-setuptools: update 58.5.3 -> 59.2.0
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch4
-rw-r--r--meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch13
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_59.2.0.bb (renamed from meta/recipes-devtools/python/python3-setuptools_58.5.3.bb)2
3 files changed, 10 insertions, 9 deletions
diff --git a/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch b/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch
index c5d6c64eda..4958e8e63d 100644
--- a/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch
+++ b/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch
@@ -1,4 +1,4 @@
-From dd77d2f4486079380235ed0466d2eab110f7bdc5 Mon Sep 17 00:00:00 2001
+From 1f578f993aae157f42923624042fafe4b01add10 Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Tue, 17 Jul 2018 10:13:38 +0800
Subject: [PATCH] conditionally do not fetch code by easy_install
@@ -15,7 +15,7 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
1 file changed, 5 insertions(+)
diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
-index 1aed0e8..f491c0a 100644
+index fc848d0..c04a5de 100644
--- a/setuptools/command/easy_install.py
+++ b/setuptools/command/easy_install.py
@@ -642,6 +642,11 @@ class easy_install(Command):
diff --git a/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch b/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
index 565cf8ae8d..3150187951 100644
--- a/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
+++ b/meta/recipes-devtools/python/python3-setuptools/0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch
@@ -1,4 +1,4 @@
-From 44349672cbff8945693c8d2821c82e9f04bfc8b5 Mon Sep 17 00:00:00 2001
+From 1ff575308248b183639c8cb14afee7c8572bd2b8 Mon Sep 17 00:00:00 2001
From: Tim Orling <timothy.t.orling@intel.com>
Date: Wed, 20 Oct 2021 17:38:10 +0000
Subject: [PATCH] _distutils/sysconfig: append
@@ -15,18 +15,19 @@ from Alex Kanavin <alex.kanavin@gmail.com>
Upstream-Status: Inappropriate [oe-specific]
Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
+
---
setuptools/_distutils/sysconfig.py | 2 ++
1 file changed, 2 insertions(+)
diff --git a/setuptools/_distutils/sysconfig.py b/setuptools/_distutils/sysconfig.py
-index 8832b3e..bbc7c08 100644
+index d36d94f..616eb91 100644
--- a/setuptools/_distutils/sysconfig.py
+++ b/setuptools/_distutils/sysconfig.py
-@@ -461,6 +461,8 @@ def _init_posix():
- platform=sys.platform,
- multiarch=getattr(sys.implementation, '_multiarch', ''),
- ))
+@@ -484,6 +484,8 @@ def _init_posix():
+ multiarch=getattr(sys.implementation, '_multiarch', ''),
+ ),
+ )
+ if 'STAGING_LIBDIR' in os.environ:
+ sys.path.append(os.environ['STAGING_LIBDIR']+'/python-sysconfigdata')
try:
diff --git a/meta/recipes-devtools/python/python3-setuptools_58.5.3.bb b/meta/recipes-devtools/python/python3-setuptools_59.2.0.bb
index ddc3fca354..704f58abd3 100644
--- a/meta/recipes-devtools/python/python3-setuptools_58.5.3.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_59.2.0.bb
@@ -13,7 +13,7 @@ SRC_URI += "\
file://0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch \
"
-SRC_URI[sha256sum] = "dae6b934a965c8a59d6d230d3867ec408bb95e73bd538ff77e71fedf1eaca729"
+SRC_URI[sha256sum] = "157d21de9d055ab9e8ea3186d91e7f4f865e11f42deafa952d90842671fc2576"
DEPENDS += "${PYTHON_PN}"