aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-23 20:35:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 14:59:50 +0100
commitb23855fd0bbd06d79bffc03fadf5012908df72d4 (patch)
treecb10d983beb8dfad76b03feb220e7d833da23867
parent09fab50b9b0c403c5c8f1139c9f9aa33a7e98dc4 (diff)
downloadopenembedded-core-contrib-b23855fd0bbd06d79bffc03fadf5012908df72d4.tar.gz
insserv: Fix build with gcc5 and clang
Kill 2 bugs with one patch | insserv.c:997:5: note: each undeclared identifier is reported only once for each function it appears in | insserv.c:997:15: error: expected ';' before 'char' | extension char buf[strlen(myname)+2+strlen(fmt)+1]; | ^ | insserv.c: In function 'main': | insserv.c:2379:5: error: 'extension' undeclared (first use in this function) | extension char * argr[argc]; | ^ | insserv.c:2379:15: error: expected ';' before 'char' | extension char * argr[argc]; | ^ | insserv.c:2401:2: error: 'argr' undeclared (first use in this function) | argr[c] = (char*)0; | ^ Change-Id: I36b7fb9e8baeda5a7cc252da10c0527401248226 (From OE-Core rev: c0f074714e34145dd6cdac6df5c325fdce649f01) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/insserv/files/161_bts777914_fix_undeclared_identifier.patch36
-rw-r--r--meta/recipes-devtools/insserv/insserv_1.14.0.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/insserv/files/161_bts777914_fix_undeclared_identifier.patch b/meta/recipes-devtools/insserv/files/161_bts777914_fix_undeclared_identifier.patch
new file mode 100644
index 0000000000..6ee9532a6b
--- /dev/null
+++ b/meta/recipes-devtools/insserv/files/161_bts777914_fix_undeclared_identifier.patch
@@ -0,0 +1,36 @@
+Upstream-Status: Pending
+
+insserv (1.14.0-5.1) UNRELEASED; urgency=low
+
+ * Non-maintainer upload.
+ * moving definition of "extension" in listing.h outside of
+ an if loop with condition related to __STDC_VERSION__.
+ * I observed that this gets build with gcc-4.9.2, as for gcc
+ __STDC_VERSION__ is not defined.
+ * I got these error while using clang to build this package.
+ * I tested it with clang-3.5(__STDC_VERSION__ 199901L) and
+ clang 3.7(__STDC_VERSION__ 201112L) and getting same error
+ described in in Bug #777914.
+
+ -- Mohit Bhakkad <mohit.bhakkad@gmail.com> Sat, 04 Apr 2015 19:14:48 +0000
+
+ insserv (1.14.0-5) unstable; urgency=low
+
+ * Add +mountall-bootclean to $local_fs virtual facility definition in
+Index: insserv-1.14.0/listing.h
+===================================================================
+--- insserv-1.14.0.orig/listing.h
++++ insserv-1.14.0/listing.h
+@@ -47,9 +47,9 @@ typedef unsigned int uint;
+ # ifndef asm
+ # define asm __asm__
+ # endif
+-# ifndef extension
+-# define extension __extension__
+-# endif
++#endif
++#ifndef extension
++# define extension __extension__
+ #endif
+ #ifndef attribute
+ # define attribute(attr) __attribute__(attr)
diff --git a/meta/recipes-devtools/insserv/insserv_1.14.0.bb b/meta/recipes-devtools/insserv/insserv_1.14.0.bb
index 4a33e16912..b66e98b49f 100644
--- a/meta/recipes-devtools/insserv/insserv_1.14.0.bb
+++ b/meta/recipes-devtools/insserv/insserv_1.14.0.bb
@@ -11,6 +11,7 @@ PR = "r1"
SRC_URI = "ftp://ftp.suse.com/pub/projects/init/${BPN}-${PV}.tar.bz2 \
file://makefile.patch \
file://disable_runtests.patch \
+ file://161_bts777914_fix_undeclared_identifier.patch \
file://insserv.conf \
file://run-ptest \
"