summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2020-02-22 18:49:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-22 23:51:46 +0000
commit7214af1d8ed9082cb4646951df8b5d97591a4876 (patch)
tree89dae67b84971a202de56624e10a45a727fda6af
parentfb1f1a1e6461b5d3c51fbae0b893debb88bfa8d5 (diff)
downloadopenembedded-core-contrib-7214af1d8ed9082cb4646951df8b5d97591a4876.tar.gz
libwpe, wpebackend-fdo: add opengl to required DISTRO_FEATURES
* requires virtual/egl which isn't available without opengl in DISTRO_FEATURES as shown in world builds without it: ERROR: Nothing PROVIDES 'virtual/egl' (but openembedded-core/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb, openembedded-core/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb DEPENDS on or otherwise requires it) $ bitbake libwpe NOTE: Resolving any missing task queue dependencies ERROR: Nothing PROVIDES 'virtual/egl' (but /OE/build/oe-core/openembedded-core/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb DEPENDS on or otherwise requires it). Close matches: virtual/kernel virtual/make virtual/perf ERROR: Required build target 'libwpe' has no buildable providers. Missing or unbuildable dependency chain was: ['libwpe', 'virtual/egl'] $ bitbake wpebackend-fdo NOTE: Resolving any missing task queue dependencies ERROR: Nothing PROVIDES 'virtual/egl' (but /OE/build/oe-core/openembedded-core/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb DEPENDS on or otherwise requires it). Close matches: virtual/kernel virtual/make virtual/perf ERROR: Required build target 'wpebackend-fdo' has no buildable providers. Missing or unbuildable dependency chain was: ['wpebackend-fdo', 'virtual/egl'] $ bitbake webkitgtk ERROR: Nothing PROVIDES 'webkitgtk' webkitgtk was skipped: missing required distro feature 'opengl' (not in DISTRO_FEATURES) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/webkit/libwpe_1.4.0.1.bb4
-rw-r--r--meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb4
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb b/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb
index 346ca9b1d8..12499ff281 100644
--- a/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb
+++ b/meta/recipes-sato/webkit/libwpe_1.4.0.1.bb
@@ -9,7 +9,9 @@ DEPENDS = "virtual/egl libxkbcommon"
# Workaround build issue with RPi userland EGL libraries.
CFLAGS_append_rpi = " ${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', '-D_GNU_SOURCE', d)}"
-inherit cmake
+inherit cmake features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "09849dfb34877354f34f318e138971cf22e677b2179e1f0a8ea00ab0b7bd8e9b"
diff --git a/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb b/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
index 7db5806d9d..cd2f7fabda 100644
--- a/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
+++ b/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
@@ -8,7 +8,9 @@ DEPENDS = "glib-2.0 libxkbcommon wayland virtual/egl libwpe"
DEPENDS_append_class-target = " wayland-native"
-inherit cmake
+inherit cmake features_check
+
+REQUIRED_DISTRO_FEATURES = "opengl"
SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "6249a0b7cbfa662206a8d2fa24e2c574e75c681ad0e93468091f1dc68ddb299d"