aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-02-11 16:09:49 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-02-11 16:09:49 +0000
commita0795895e317fddb212dc531e2ac8943f433c562 (patch)
treeabc2239a964b1e92c8c9d4043e6d78610ccb9628
parente49fcdcc8b1855368b33b4510d1030702926d720 (diff)
downloadopenembedded-core-contrib-a0795895e317fddb212dc531e2ac8943f433c562.tar.gz
xserver-nodm-init: Make sure kdrive servers have the console keyboard enabled
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--meta/packages/x11-common/x11-common/etc/X11/Xserver8
-rw-r--r--meta/packages/x11-common/xserver-nodm-init.bb4
2 files changed, 4 insertions, 8 deletions
diff --git a/meta/packages/x11-common/x11-common/etc/X11/Xserver b/meta/packages/x11-common/x11-common/etc/X11/Xserver
index 9a0986ad61..3d4aa74b95 100644
--- a/meta/packages/x11-common/x11-common/etc/X11/Xserver
+++ b/meta/packages/x11-common/x11-common/etc/X11/Xserver
@@ -30,12 +30,9 @@ ARGS=" -br -pn"
if [ "$XSERVER" != "/usr/bin/Xorg" ]; then
- . /etc/formfactor/config
+ . /etc/formfactor/config
- # use ucb 1x00 touchscreen if present
- if [ -z "$TSLIB_TSDEVICE" ] && [ -e /dev/touchscreen/ucb1x00 ]; then
- ARGS="$ARGS -mouse /dev/touchscreen/ucb1x00"
- fi
+ ARGS="$ARGS -keybd keyboard"
# use usb mouse if present
if [ -z "$TSLIB_TSDEVICE" ] && [ -e /dev/input/mice ]; then
@@ -78,4 +75,3 @@ fi
DISPLAY=':0'
exec xinit /etc/X11/Xsession -- $XSERVER $DISPLAY $ARGS $*
-
diff --git a/meta/packages/x11-common/xserver-nodm-init.bb b/meta/packages/x11-common/xserver-nodm-init.bb
index c9efb71b81..c77b2f0f8b 100644
--- a/meta/packages/x11-common/xserver-nodm-init.bb
+++ b/meta/packages/x11-common/xserver-nodm-init.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Simple Xserver Init Script (no dm)"
LICENSE = "GPL"
SECTION = "x11"
PRIORITY = "optional"
-PR = "r21"
+PR = "r22"
RDEPENDS_${PN} = "dbus-wait sudo"
SRC_URI = "file://xserver-nodm"
@@ -14,7 +14,7 @@ do_install() {
install -d ${D}/etc
install -d ${D}/etc/init.d
install xserver-nodm ${D}/etc/init.d
-}
+}
inherit update-rc.d