aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-17 11:48:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-20 21:22:28 +0000
commitdceac54e05bb786e19de8db33982a8d54e41a915 (patch)
treed21789d88b4ab05bbaf916ba59d726316b6d4dd7
parenta50aa22a229e8c13d36528a9e5a776688a5133a7 (diff)
downloadopenembedded-core-contrib-dceac54e05bb786e19de8db33982a8d54e41a915.tar.gz
python3-setuptools: upgrade 40.0.0 -> 40.8.0
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch10
-rw-r--r--meta/recipes-devtools/python/python-setuptools.inc4
-rw-r--r--meta/recipes-devtools/python/python-setuptools_40.8.0.bb (renamed from meta/recipes-devtools/python/python-setuptools_40.0.0.bb)0
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_40.8.0.bb (renamed from meta/recipes-devtools/python/python3-setuptools_40.0.0.bb)0
4 files changed, 6 insertions, 8 deletions
diff --git a/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch b/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch
index 4b17921880..169d1b155b 100644
--- a/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch
+++ b/meta/recipes-devtools/python/files/0001-conditionally-do-not-fetch-code-by-easy_install.patch
@@ -1,4 +1,4 @@
-From 019422d19c6401fa8f45b1311ecd31bb087c809d Mon Sep 17 00:00:00 2001
+From 5bba4f57f048016aa92ce5909e9e372db619554e Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Tue, 17 Jul 2018 10:13:38 +0800
Subject: [PATCH] conditionally do not fetch code by easy_install
@@ -9,15 +9,16 @@ internet by easy_install.
Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+
---
setuptools/command/easy_install.py | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/setuptools/command/easy_install.py b/setuptools/command/easy_install.py
-index 85ee40f..7eb9d2a 100755
+index 05508ce..945e118 100755
--- a/setuptools/command/easy_install.py
+++ b/setuptools/command/easy_install.py
-@@ -637,6 +637,11 @@ class easy_install(Command):
+@@ -640,6 +640,11 @@ class easy_install(Command):
os.path.exists(tmpdir) and rmtree(rmtree_safe(tmpdir))
def easy_install(self, spec, deps=False):
@@ -29,6 +30,3 @@ index 85ee40f..7eb9d2a 100755
if not self.editable:
self.install_site_py()
---
-2.7.4
-
diff --git a/meta/recipes-devtools/python/python-setuptools.inc b/meta/recipes-devtools/python/python-setuptools.inc
index 315ba31396..9092d7ad03 100644
--- a/meta/recipes-devtools/python/python-setuptools.inc
+++ b/meta/recipes-devtools/python/python-setuptools.inc
@@ -10,8 +10,8 @@ inherit pypi
SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
-SRC_URI[md5sum] = "260630ae1a64bafa39dcc53404d63829"
-SRC_URI[sha256sum] = "012adb8e25fbfd64c652e99e7bab58799a3aaf05d39ab38561f69190a909015f"
+SRC_URI[md5sum] = "712697a5bc975cf479d487cd68206c20"
+SRC_URI[sha256sum] = "6e4eec90337e849ade7103723b9a99631c1f0d19990d6e8412dc42f5ae8b304d"
DEPENDS += "${PYTHON_PN}"
diff --git a/meta/recipes-devtools/python/python-setuptools_40.0.0.bb b/meta/recipes-devtools/python/python-setuptools_40.8.0.bb
index cf9440495b..cf9440495b 100644
--- a/meta/recipes-devtools/python/python-setuptools_40.0.0.bb
+++ b/meta/recipes-devtools/python/python-setuptools_40.8.0.bb
diff --git a/meta/recipes-devtools/python/python3-setuptools_40.0.0.bb b/meta/recipes-devtools/python/python3-setuptools_40.8.0.bb
index 0dc1ed8622..0dc1ed8622 100644
--- a/meta/recipes-devtools/python/python3-setuptools_40.0.0.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_40.8.0.bb