aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2017-06-21 19:18:26 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-28 15:51:55 +0100
commitdbf680ce09ce54f97c781fc7a8e5e05ed4706073 (patch)
treede7f656cdc3d9320500dccc047ab7fd2812ba88f
parent544e04a11ab6c26a367ac0b67774bf7ffdf43c88 (diff)
downloadopenembedded-core-contrib-dbf680ce09ce54f97c781fc7a8e5e05ed4706073.tar.gz
selftest/devtool: Don't use removed remake as test case
remake was removed from oe-core: use another recipe in the devtool extract test. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
-rw-r--r--meta/lib/oeqa/selftest/cases/devtool.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/lib/oeqa/selftest/cases/devtool.py b/meta/lib/oeqa/selftest/cases/devtool.py
index a7fde201fb..88d69724f9 100644
--- a/meta/lib/oeqa/selftest/cases/devtool.py
+++ b/meta/lib/oeqa/selftest/cases/devtool.py
@@ -1094,8 +1094,7 @@ class DevtoolTests(DevtoolBase):
tempdir = tempfile.mkdtemp(prefix='devtoolqa')
# Try devtool extract
self.track_for_cleanup(tempdir)
- self.append_config('PREFERRED_PROVIDER_virtual/make = "remake"')
- result = runCmd('devtool extract remake %s' % tempdir)
+ result = runCmd('devtool extract matchbox-terminal %s' % tempdir)
self.assertExists(os.path.join(tempdir, 'Makefile.am'), 'Extracted source could not be found')
# devtool extract shouldn't create the workspace
self.assertNotExists(self.workspacedir)