aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-02-20 09:26:37 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-20 14:47:48 +0000
commita8eb060cbbbb00581e8260dd6bfc31cff5558e8f (patch)
tree93aa0c2969f86959772959d6c8faeea7ba655c0e
parent2db2bfa47dd3e04b67e5a1642d36ac6f1eff245f (diff)
downloadopenembedded-core-contrib-a8eb060cbbbb00581e8260dd6bfc31cff5558e8f.tar.gz
linux-yocto/4.12: fix qemuarm64 boot failure
The -stable update to 4.12 needs one more commit to fix the boot of qemuarm64. This will be part of the next 4.12 -stable series, but for now, we merge the patch directly. 40146055677a mm/sparsemem: Fix ARM64 boot crash when CONFIG_SPARSEMEM_EXTREME=y Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.12.bb16
3 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
index a471d1abea..4eb0156629 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "8bade20d734f0b5e6ed13414b96cecaabe0c8039"
+SRCREV_machine ?= "33aa1a4ea44399f12dfb26146ea06db5cd02ca69"
SRCREV_meta ?= "19d815d5a34bfaad95d87cc097cef18b594daac8"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
index f1a9c1d9fd..3ff2e1ce19 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.12.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.12.20"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "1c4ad569af3e23a77994235435040e322908687f"
+SRCREV_machine ?= "40146055677a69730b2c36da1c8c1b4e9bae7bb0"
SRCREV_meta ?= "19d815d5a34bfaad95d87cc097cef18b594daac8"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.12.bb b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
index 3916c6c39d..b10b82b771 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
@@ -11,14 +11,14 @@ KBRANCH_qemux86 ?= "standard/base"
KBRANCH_qemux86-64 ?= "standard/base"
KBRANCH_qemumips64 ?= "standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "9728502c1fc96a1348ff06e1be8df75bee168032"
-SRCREV_machine_qemuarm64 ?= "1c4ad569af3e23a77994235435040e322908687f"
-SRCREV_machine_qemumips ?= "b04e654320e56fa42e477698dbf61d99f0bb4501"
-SRCREV_machine_qemuppc ?= "1c4ad569af3e23a77994235435040e322908687f"
-SRCREV_machine_qemux86 ?= "1c4ad569af3e23a77994235435040e322908687f"
-SRCREV_machine_qemux86-64 ?= "1c4ad569af3e23a77994235435040e322908687f"
-SRCREV_machine_qemumips64 ?= "7a297c3848d02c46acd40e3d2f285c7905f8134c"
-SRCREV_machine ?= "1c4ad569af3e23a77994235435040e322908687f"
+SRCREV_machine_qemuarm ?= "6e5a99db3a495e023041a30d43262047795e645a"
+SRCREV_machine_qemuarm64 ?= "40146055677a69730b2c36da1c8c1b4e9bae7bb0"
+SRCREV_machine_qemumips ?= "43dc47f90007d54c7086cc03b28e946e30135f1c"
+SRCREV_machine_qemuppc ?= "40146055677a69730b2c36da1c8c1b4e9bae7bb0"
+SRCREV_machine_qemux86 ?= "40146055677a69730b2c36da1c8c1b4e9bae7bb0"
+SRCREV_machine_qemux86-64 ?= "40146055677a69730b2c36da1c8c1b4e9bae7bb0"
+SRCREV_machine_qemumips64 ?= "69f0c96d8e47b0dccfb374809d729f0042c77868"
+SRCREV_machine ?= "40146055677a69730b2c36da1c8c1b4e9bae7bb0"
SRCREV_meta ?= "19d815d5a34bfaad95d87cc097cef18b594daac8"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \