aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-02-08 12:25:28 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-23 07:28:51 -0800
commit2a78531cc9e34186e771da22f980ffc1c3cdb785 (patch)
tree51fb33b77992f117af3ae52eae5f99ae66e996b2
parent05708d430337dc2a56f0947b151dee6765025301 (diff)
downloadopenembedded-core-contrib-2a78531cc9e34186e771da22f980ffc1c3cdb785.tar.gz
python3-setuptools: extend to nativesdk
Extend python3-setuptools to nativesdk because nativesdk-python3-pip needs it. Also, adjust RDEPENDS variable setting to keep the runtime dependencies for nativesdk package the same with the target one. The native package and the target package's dependencies remain the same as before. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_32.1.1.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb b/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
index 65af6f0dad..63f241809e 100644
--- a/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
@@ -2,6 +2,7 @@ require python-setuptools.inc
DEPENDS += "python3"
DEPENDS_class-native += "python3-native"
+DEPENDS_class-nativesdk += "nativesdk-python3"
inherit distutils3
@@ -14,11 +15,11 @@ do_install_append() {
echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
}
-RDEPENDS_${PN} = "\
+RDEPENDS_${PN}_class-native = "\
python3-distutils \
python3-compression \
"
-RDEPENDS_${PN}_class-target = "\
+RDEPENDS_${PN} = "\
python3-ctypes \
python3-distutils \
python3-email \
@@ -34,4 +35,4 @@ RDEPENDS_${PN}_class-target = "\
python3-unittest \
python3-xml \
"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"