summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2024-03-15 14:37:36 +0000
committerSteve Sakoman <steve@sakoman.com>2024-03-22 06:22:00 -1000
commit000bedc1c95e033f8a479a18a47dc66a0609d596 (patch)
treebe2890fb23da5d9da80def8f2a89cc92d3e5e035
parentebbe9458526546b821d81a89d8098355d943ee60 (diff)
downloadopenembedded-core-contrib-000bedc1c95e033f8a479a18a47dc66a0609d596.tar.gz
curl: improve run-ptest
There's no need to run the output of runtests.pl through a sed to get automake-style output, as you can pass -am to get this formatting. Don't run timing dependent tests, as the ptests can run on loaded systems. Add a dependency on the en_US locale because some of the tests require this. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 3c3601d50ae290e7e9797eadd20c05df99bbd040) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-support/curl/curl/run-ptest13
-rw-r--r--meta/recipes-support/curl/curl_8.4.0.bb1
2 files changed, 10 insertions, 4 deletions
diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 8f9c20f34d..acd2892f80 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,11 @@
#!/bin/sh
+
cd tests
-{ ./runtests.pl -a -n -s -j4 !flaky || echo "FAIL: curl" ; } | sed \
- -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
- -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
- -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'
+
+# Run all tests, don't stop on first failure
+# Don't use valgrind if it is found
+# Use automake-style output
+# Run four tests in parallel
+# Print log output on failure
+# Don't run the flaky or timing dependent tests
+./runtests.pl -a -n -am -j4 -p '!flaky !timing-dependent'
diff --git a/meta/recipes-support/curl/curl_8.4.0.bb b/meta/recipes-support/curl/curl_8.4.0.bb
index 977404c963..bb46efb1e7 100644
--- a/meta/recipes-support/curl/curl_8.4.0.bb
+++ b/meta/recipes-support/curl/curl_8.4.0.bb
@@ -127,6 +127,7 @@ RDEPENDS:${PN}-ptest += " \
perl-module-storable \
perl-module-time-hires \
"
+RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
PACKAGES =+ "lib${BPN}"