summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2022-07-01 07:01:17 -1000
committerSteve Sakoman <steve@sakoman.com>2022-07-01 08:35:07 -1000
commitf90647e9dd95cfd29b5bdb8d7dcd688a10fc060c (patch)
tree66fd13b6b037d15acb261c58f60b76bba61e52ce
parentd6344cca6c76f0f8a89b576babe2ce36ce5ed049 (diff)
downloadopenembedded-core-contrib-f90647e9dd95cfd29b5bdb8d7dcd688a10fc060c.tar.gz
openssh: break dependency on base package for -dev package
Otherwise the SDK fails to build as the main openssh and dropbear packages conflict with each other Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-connectivity/openssh/openssh_8.9p1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssh/openssh_8.9p1.bb b/meta/recipes-connectivity/openssh/openssh_8.9p1.bb
index f306b1245a..a3a0016ce5 100644
--- a/meta/recipes-connectivity/openssh/openssh_8.9p1.bb
+++ b/meta/recipes-connectivity/openssh/openssh_8.9p1.bb
@@ -166,6 +166,11 @@ RRECOMMENDS:${PN}-sshd:append:class-target = "\
${@bb.utils.filter('PACKAGECONFIG', 'rng-tools', d)} \
"
+# break dependency on base package for -dev package
+# otherwise SDK fails to build as the main openssh and dropbear packages
+# conflict with each other
+RDEPENDS:${PN}-dev = ""
+
# gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies
RDEPENDS:${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed sudo coreutils"