summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry Baryshkov <dbaryshkov@gmail.com>2022-06-01 14:08:16 +0300
committerSteve Sakoman <steve@sakoman.com>2022-06-20 06:47:01 -1000
commit96cd37cff9caaf3e92cbf63660e9b6bc73fa9744 (patch)
tree3416f91d7eb0620a20f273c26ad767d641508e99
parentfeabc35372e78575ff04ea207b34f2d278a75d00 (diff)
downloadopenembedded-core-contrib-96cd37cff9caaf3e92cbf63660e9b6bc73fa9744.tar.gz
linux-firmware: add support for building snapshots
In some cases it is useful to be able to test the snapshot of linux-firmware (e.g. to test if the updated firmware works on the particular hardware). Allow building the linux-firmware snapshots. To switch to the most recent branch, add the following lines to the local.conf file: PREFERRED_VERSION_linux-firmware = "1:20220509+git%" SRCREV:class-devupstream = "${AUTOREV}" WHENCE_CHKSUM:class-devupstream:pn-linux-firmware = "4288aad55d189fa225d492526b8406d5" Signed-off-by: Dmitry Baryshkov <dmitry.baryshkov@linaro.org> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit b023570ae1d239de14b50a0e827582d0e84ddf81) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-kernel/linux-firmware/linux-firmware_20220509.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux-firmware/linux-firmware_20220509.bb b/meta/recipes-kernel/linux-firmware/linux-firmware_20220509.bb
index 6e328e5726..10a7036a19 100644
--- a/meta/recipes-kernel/linux-firmware/linux-firmware_20220509.bb
+++ b/meta/recipes-kernel/linux-firmware/linux-firmware_20220509.bb
@@ -69,6 +69,7 @@ LICENSE = "\
& WHENCE \
"
+WHENCE_CHKSUM = "d3eb82686904888f8bbbe8d865371404"
LIC_FILES_CHKSUM = "file://LICENCE.Abilis;md5=b5ee3f410780e56711ad48eadc22b8bc \
file://LICENCE.adsp_sst;md5=615c45b91a5a4a9fe046d6ab9a2df728 \
file://LICENCE.agere;md5=af0133de6b4a9b2522defd5f188afd31 \
@@ -132,7 +133,7 @@ LIC_FILES_CHKSUM = "file://LICENCE.Abilis;md5=b5ee3f410780e56711ad48eadc22b8bc \
file://LICENCE.xc4000;md5=0ff51d2dc49fce04814c9155081092f0 \
file://LICENCE.xc5000;md5=1e170c13175323c32c7f4d0998d53f66 \
file://LICENCE.xc5000c;md5=12b02efa3049db65d524aeb418dd87ca \
- file://WHENCE;md5=d3eb82686904888f8bbbe8d865371404 \
+ file://WHENCE;md5=${WHENCE_CHKSUM} \
"
# These are not common licenses, set NO_GENERIC_LICENSE for them
@@ -208,6 +209,11 @@ SRC_URI = "\
file://0001-Makefile-replace-mkdir-by-install.patch \
"
+BBCLASSEXTEND = "devupstream:target"
+SRC_URI:class-devupstream = "git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git;protocol=https;branch=main"
+# Pin this to the 20220509 release, override this in local.conf
+SRCREV:class-devupstream ?= "b19cbdca78ab2adfd210c91be15a22568e8b8cae"
+
SRC_URI[sha256sum] = "376e0b3d7b4f8aaa2abf7f5ab74803dcf14b06b94e3d841b1467cd9a2848255e"
inherit allarch