summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Roussin-Bélanger <maxime.roussinbelanger@gmail.com>2022-06-21 10:26:19 -0400
committerSteve Sakoman <steve@sakoman.com>2022-07-01 06:23:58 -1000
commit58804e0051e3b77e0378aa4accbd26b2588b68e7 (patch)
treed27f19f05afc5e12833c8054c8b81ee84e143f00
parent0a3ebc5584384e4bf7d9c7ba4c827db587ef3bee (diff)
downloadopenembedded-core-contrib-58804e0051e3b77e0378aa4accbd26b2588b68e7.tar.gz
libffi: fix native build being not portable
Without `--with-gcc-arch=generic` libffi looks up the cpuid to automatically determine which mtune/march to use. This makes the native sstate-cache unuseable since it's possible to have a newer cpu building the recipe and the library being pulled from another older cpu which doesn't have the instruction. Signed-off-by: Maxime Roussin-Bélanger <maxime.roussinbelanger@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit cddaecac1fdd4d033c2ff8ccaf1d60e1c598d5b7) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-support/libffi/libffi_3.4.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/libffi/libffi_3.4.2.bb b/meta/recipes-support/libffi/libffi_3.4.2.bb
index 733fcc5e6c..71d9518baf 100644
--- a/meta/recipes-support/libffi/libffi_3.4.2.bb
+++ b/meta/recipes-support/libffi/libffi_3.4.2.bb
@@ -19,6 +19,7 @@ UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
EXTRA_OECONF += "--disable-builddir --disable-exec-static-tramp"
+EXTRA_OECONF:class-native += "--with-gcc-arch=generic"
EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
inherit autotools texinfo multilib_header
@@ -33,4 +34,3 @@ FILES:${PN}-dev += "${libdir}/libffi-${PV}"
MIPS_INSTRUCTION_SET = "mips"
BBCLASSEXTEND = "native nativesdk"
-