summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-12-01 15:42:32 +0000
committerAnuj Mittal <anuj.mittal@intel.com>2021-12-07 14:55:55 +0800
commitd647fa0136bde43544b142136f519b597ed749c1 (patch)
tree5cff50fbedb8d7f7993d3c66a2f3b91483a2ce87
parenta1284b80c48328845d67c2bbc9f45207b71264d3 (diff)
downloadopenembedded-core-contrib-d647fa0136bde43544b142136f519b597ed749c1.tar.gz
recipetool: extend curl detection when creating recipes
If a configure.ac uses LIBCURL_CHECK_CONFIG it wants curl. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 16e830ca1352cee61e4ae4b98b1203f849bf71f3) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--scripts/lib/recipetool/create_buildsys.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/scripts/lib/recipetool/create_buildsys.py b/scripts/lib/recipetool/create_buildsys.py
index 35a97c9345..5015634476 100644
--- a/scripts/lib/recipetool/create_buildsys.py
+++ b/scripts/lib/recipetool/create_buildsys.py
@@ -545,7 +545,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
deps.append('zlib')
elif keyword in ('AX_CHECK_OPENSSL', 'AX_LIB_CRYPTO'):
deps.append('openssl')
- elif keyword == 'AX_LIB_CURL':
+ elif keyword in ('AX_LIB_CURL', 'LIBCURL_CHECK_CONFIG'):
deps.append('curl')
elif keyword == 'AX_LIB_BEECRYPT':
deps.append('beecrypt')
@@ -624,6 +624,7 @@ class AutotoolsRecipeHandler(RecipeHandler):
'AX_CHECK_OPENSSL',
'AX_LIB_CRYPTO',
'AX_LIB_CURL',
+ 'LIBCURL_CHECK_CONFIG',
'AX_LIB_BEECRYPT',
'AX_LIB_EXPAT',
'AX_LIB_GCRYPT',