summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenfe-Mickael Laventure <mickael.laventure@verkada.com>2021-09-27 09:45:45 -0700
committerAnuj Mittal <anuj.mittal@intel.com>2021-10-04 10:46:18 +0800
commitc4724cd652b5a3adc398652b48e16d1fd1a90e89 (patch)
treead54dd07430e3a6af7952e594d09fc9afd21fdad
parentf730707b3e00e5d9d145d55cdf479cd6d11a62f5 (diff)
downloadopenembedded-core-contrib-c4724cd652b5a3adc398652b48e16d1fd1a90e89.tar.gz
package_ipk: Use localdata store when signing packages
When signing a package, we were resolving the `PKGV` version using the original data store (`d`). However, since that store does not have the package name in its `OVERRIDES` list the wrong version can be returned in recipes that produce multiple packages. One such example would be `external-arm-toolchain.bb`. The above issue is fixed by using `localdata` instead of `d` when resolving the needed variables. Signed-off-by: Kenfe-Mickael Laventure <mickael.laventure@verkada.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 2b5f01cf5a92a873ac4c3f0ba0584cab2cc05714) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/classes/package_ipk.bbclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index 600b3ac90c..67d6007e11 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -230,8 +230,8 @@ def ipk_write_pkg(pkg, d):
shell=True)
if d.getVar('IPK_SIGN_PACKAGES') == '1':
- ipkver = "%s-%s" % (d.getVar('PKGV'), d.getVar('PKGR'))
- ipk_to_sign = "%s/%s_%s_%s.ipk" % (pkgoutdir, pkgname, ipkver, d.getVar('PACKAGE_ARCH'))
+ ipkver = "%s-%s" % (localdata.getVar('PKGV'), localdata.getVar('PKGR'))
+ ipk_to_sign = "%s/%s_%s_%s.ipk" % (pkgoutdir, pkgname, ipkver, localdata.getVar('PACKAGE_ARCH'))
sign_ipk(d, ipk_to_sign)
finally: