summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRahul Kumar <rahulk@mvista.com>2020-09-06 23:01:28 +0530
committerSteve Sakoman <steve@sakoman.com>2020-09-14 04:26:37 -1000
commitedaecac74210ae201dc5eea5758bcf4e85cb14cb (patch)
treef20e9de2435348ca8396eef096232e7b53f94e71
parentb98e50f08b2bcf61fbc75ea1b0ad83a17c0a736a (diff)
downloadopenembedded-core-contrib-edaecac74210ae201dc5eea5758bcf4e85cb14cb.tar.gz
systemd-serialgetty: Fix sed expression quoting
Fix sed: -e expression #1, char 13: unterminated `s' command Error Message: | NOTE: Installed into sysroot: [] | NOTE: Skipping as already exists in sysroot: ['pseudo-native', 'glibc', 'patch-native', 'quilt-native', 'gcc-cross-arm', 'gcc-runtime', 'linux-libc-headers', 'libgcc', 'flex-native', 'xz-native', 'libtool-native', 'automake-native', 'binutils-cross-arm', 'zlib-native', 'mpfr-native', 'texinfo-dummy-native', 'autoconf-native', 'libmpc-native', 'gnu-config-native', 'gmp-native', 'attr-native', 'm4-native', 'gettext-minimal-native'] | DEBUG: Python function extend_recipe_sysroot finished | DEBUG: Executing shell function do_install | sed: -e expression #1, char 13: unterminated `s' command | WARNING: exit code 1 from a shell command. | ERROR: Execution of '/opt/Projects/poky/build/tmp/work/qemux86_64-poky-linux/systemd-serialgetty/1.0-r5/temp/run.do_install.11228' failed with exit code 1: | sed: -e expression #1, char 13: unterminated `s' command | WARNING: exit code 1 from a shell command. | To Fix this Issue using the strong (single quote) character in sed command. It is recommend to use quotes. If we have meta-characters in the command, quotes are necessary. Signed-off-by: Rahul Kumar <rahulk@mvista.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit e2fea05e150dcfec4b7dfbd8edddb53897026bf9) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 044c6c5b67..059fccc2b6 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -21,7 +21,7 @@ do_install() {
install -d ${D}${systemd_unitdir}/system/
install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/
install -m 0644 ${WORKDIR}/serial-getty@.service ${D}${systemd_unitdir}/system/
- sed -i -e s/\@BAUDRATE\@/$default_baudrate/g ${D}${systemd_unitdir}/system/serial-getty@.service
+ sed -i -e 's/\@BAUDRATE\@/$default_baudrate/g' ${D}${systemd_unitdir}/system/serial-getty@.service
tmp="${SERIAL_CONSOLES}"
for entry in $tmp ; do