summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan.schmidt@huawei.com>2021-03-18 14:22:37 +0100
committerSteve Sakoman <steve@sakoman.com>2021-03-20 06:27:38 -1000
commitc88bb3db92d0650a560d7cbc1f0f42ae8faf15e1 (patch)
treed71ffd03fb363075b65d1e1b4cd960c6c234b2e5
parent71aac912966eccdd92fbe93e4555a4939b8973d5 (diff)
downloadopenembedded-core-contrib-c88bb3db92d0650a560d7cbc1f0f42ae8faf15e1.tar.gz
systemd-conf: do not ask for DHCP if configured on kernel command line
In cases where we configure the IP address and more on the kernel command line with ip= we should not ask for DHCP with systemd-networkd later on. We have such a setup with our runqemu script. With this match in place we can also deploy this unit on qemu systems. Signed-off-by: Stefan Schmidt <stefan.schmidt@huawei.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 8c4981e740c0e630200dbc77c9e3dfd3e43b790b)
-rw-r--r--meta/recipes-core/systemd/systemd-conf/wired.network1
-rw-r--r--meta/recipes-core/systemd/systemd-conf_244.3.bb3
2 files changed, 1 insertions, 3 deletions
diff --git a/meta/recipes-core/systemd/systemd-conf/wired.network b/meta/recipes-core/systemd/systemd-conf/wired.network
index ff807ba31f..34c20fcb24 100644
--- a/meta/recipes-core/systemd/systemd-conf/wired.network
+++ b/meta/recipes-core/systemd/systemd-conf/wired.network
@@ -1,6 +1,7 @@
[Match]
Name=en* eth*
KernelCommandLine=!nfsroot
+KernelCommandLine=!ip
[Network]
DHCP=yes
diff --git a/meta/recipes-core/systemd/systemd-conf_244.3.bb b/meta/recipes-core/systemd/systemd-conf_244.3.bb
index d9ec023bfd..9b797a91f4 100644
--- a/meta/recipes-core/systemd/systemd-conf_244.3.bb
+++ b/meta/recipes-core/systemd/systemd-conf_244.3.bb
@@ -23,9 +23,6 @@ do_install() {
# Based on change from YP bug 8141, OE commit 5196d7bacaef1076c361adaa2867be31759c1b52
do_install_append_qemuall() {
install -D -m0644 ${WORKDIR}/system.conf-qemuall ${D}${systemd_unitdir}/system.conf.d/01-${PN}.conf
-
- # Do not install wired.network for qemu bsps
- rm -rf ${D}${systemd_unitdir}/network
}
PACKAGE_ARCH = "${MACHINE_ARCH}"