summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-12 11:45:26 +0100
committerSteve Sakoman <steve@sakoman.com>2021-10-19 04:04:49 -1000
commit8fc9963d70247d243c8fc5597d68d88a1757f2fd (patch)
tree9d9b148ab0fb3ed82c3cd47b31b518ecc903756b
parente570efa43d5655afa041bd4ab52fec2de2216e4d (diff)
downloadopenembedded-core-contrib-8fc9963d70247d243c8fc5597d68d88a1757f2fd.tar.gz
libnewt: Use python3targetconfig to fix reproducibility issue
We're seeing pthread being linked sometimes and not others leading to non-reproducible target binaries. The reason is mixing the native python config with the target one. We should use the target one. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 3fe5101b335384ef83e96ccc58687fd631164075) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.21.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.21.bb b/meta/recipes-extended/newt/libnewt_0.52.21.bb
index 88b4cf4a03..3d35a17c92 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.21.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.21.bb
@@ -29,7 +29,7 @@ SRC_URI[sha256sum] = "265eb46b55d7eaeb887fca7a1d51fe115658882dfe148164b6c49fccac
S = "${WORKDIR}/newt-${PV}"
-inherit autotools-brokensep python3native python3-dir
+inherit autotools-brokensep python3native python3-dir python3targetconfig
EXTRA_OECONF = "--without-tcl --with-python"