summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-14 12:05:10 +0000
committerSteve Sakoman <steve@sakoman.com>2021-03-04 04:19:49 -1000
commit52658a8df1bf86902a277f4896cf766c8391ad61 (patch)
tree18438e47a8bd73668c4099e7110cbfdc035004f8
parent56d4c2867743b4b6bf79a4a9472799038522a331 (diff)
downloadopenembedded-core-contrib-52658a8df1bf86902a277f4896cf766c8391ad61.tar.gz
cwautomacros: Ensure version is set deterministically
The makefile injects the current date into the version file. Do this deterministically with SOURCE_DATE_EPOCH. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 31f2ad739ea776a1e11b5cef5434df188007c7bf) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-extended/cwautomacros/cwautomacros_20110201.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/cwautomacros/cwautomacros_20110201.bb b/meta/recipes-extended/cwautomacros/cwautomacros_20110201.bb
index 65a99fc28d..02b016fdf1 100644
--- a/meta/recipes-extended/cwautomacros/cwautomacros_20110201.bb
+++ b/meta/recipes-extended/cwautomacros/cwautomacros_20110201.bb
@@ -13,7 +13,7 @@ do_configure() {
}
do_install() {
- oe_runmake CWAUTOMACROSPREFIX=${D}${prefix} install
+ oe_runmake LABEL=`date -d @${SOURCE_DATE_EPOCH} +%Y%m%d` CWAUTOMACROSPREFIX=${D}${prefix} install
# cleanup buildpaths in autogen.sh
sed -i -e 's,${D},,g' ${D}${prefix}/share/cwautomacros/scripts/autogen.sh