summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2021-02-12 10:51:57 -0600
committerSteve Sakoman <steve@sakoman.com>2021-03-04 04:19:49 -1000
commit42f742452df1258bd0679c115ed90c45a8a893d9 (patch)
treebf3dcfb3adce103ee06bcea20ea5c9a05c35717e
parent3720c39524df866b570540310edaac973cdad7fb (diff)
downloadopenembedded-core-contrib-42f742452df1258bd0679c115ed90c45a8a893d9.tar.gz
libomxil: Fix up commercial license flag
The commercial license flag on libomxil is set because it may include the Adaptive Multi-Rate audio codec (AMR) using FFmepg, which is patent encumbered. It turns out this component is disabled by default in the recipe; add a PACKAGECONFIG to enable it and trigger the "commercial" LICENSE_FLAGS on it. This make the default build configuration clean unless a user specifically asks for AMR support, and prevents them from marking the recipe with the "commerical" flag unnecessarily which could hide potential problems later on. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 5f61e20002c2af93e2d6810574e23606925526ee) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb b/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
index 271c2a30a3..8f3b76a920 100644
--- a/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
+++ b/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "Bellagio is an opensource implementation of the Khronos OpenMAX \
HOMEPAGE = "http://omxil.sourceforge.net/"
LICENSE = "LGPLv2.1+"
-LICENSE_FLAGS = "commercial"
+LICENSE_FLAGS = "${@bb.utils.contains('PACKAGECONFIG', 'amr', 'commercial', '', d)}"
LIC_FILES_CHKSUM = "file://COPYING;md5=ae6f0f4dbc7ac193b50f323a6ae191cb \
file://src/omxcore.h;beginline=1;endline=27;md5=806b1e5566c06486fe8e42b461e03a90"
@@ -26,6 +26,10 @@ EXTRA_OECONF += "--disable-doc --disable-Werror"
PROVIDES += "virtual/libomxil"
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[amr] = "--enable-amr,,"
+
#
# The .so files under ${libdir}/bellagio are not intended to be versioned and symlinked.
# Make sure they get packaged in the main package.