summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZbigniew Bodek <zbigniew.bodek@huawei.com>2021-02-20 02:19:54 +0900
committerSteve Sakoman <steve@sakoman.com>2021-03-04 04:19:49 -1000
commit341e18ff05bb6758e3e153ed8c27723a6f51621d (patch)
treefb983b6867c06029c46524c1c206ff0d7182c646
parent6842791f97546c963ea77215c9f5012dc40ed886 (diff)
downloadopenembedded-core-contrib-341e18ff05bb6758e3e153ed8c27723a6f51621d.tar.gz
wpebackend-fdo: Fix missing .so symlink when using dev package
Problem spotted on dunfell-23.0.4 Normally, unversioned .so is removed from -dev (default) package however it is still being referred by other agents, such as webkitgtk. That can be observed while executing i.e. Epiphany Browser. For instance: platformInitializeWebProcess() calls wpe_loader_init("libWPEBackend-fdo-1.0.so") as a result one can see: -------------------- wpe_loader_init could not load the library 'libWPEBackend-fdo-1.0.so': libWPEBackend-fdo-1.0.so: cannot open shared object file: No such file or directory -------------------- "master" branch contains a bumped-up version of webkitgtk to which this issue does not apply (the code has changed). Forcefully keep this .so symlink to resolve the problem in dunfell. Signed-off-by: Zbigniew Bodek <zbigniew.bodek@huawei.com> Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb b/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
index cd2f7fabda..165fc74dde 100644
--- a/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
+++ b/meta/recipes-sato/webkit/wpebackend-fdo_1.4.1.bb
@@ -15,3 +15,6 @@ REQUIRED_DISTRO_FEATURES = "opengl"
SRC_URI = "https://wpewebkit.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI[sha256sum] = "6249a0b7cbfa662206a8d2fa24e2c574e75c681ad0e93468091f1dc68ddb299d"
+FILES_${PN} += "${libdir}/libWPEBackend-fdo-1.0.so"
+FILES_SOLIBSDEV = ""
+INSANE_SKIP_${PN} += "dev-so"