summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaus Stovgaard <claus.stovgaard@gmail.com>2024-02-01 15:25:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-03 21:41:19 +0000
commit711fc671012820458a7a28717ee0456fa850a523 (patch)
tree1d9db1d652386578d6780b6640b81451759afc1e
parentbe83bc937a76efaead4690237db25459a57673fc (diff)
downloadopenembedded-core-contrib-711fc671012820458a7a28717ee0456fa850a523.tar.gz
kernel-devsrc: fix RDEPENDS for make
Since kernel version 6.6 the debian package rules has been split up into a separate rules file, resulting in a runtime requirement for make. See scripts/package/debian/rules Remove the rules file, for not RDEPENDS on make for something we are not using for building modules. For reproducing the issue on a normal qemux86-64 machine, change to the linux-yocto-dev kernel, add the kernel-devsrc to the toolchain target task and disable ptest in distro features. (Notice ptest adds make as RDEPENDS for other packages hiding the issue) when populating sdk you will see dnf failing. Problem: conflicting requests - nothing provides /usr/bin/make needed by kernel-devsrc-1.0-r0.qemux86_64 from oe-repo Signed-off-by: Claus Stovgaard <claus.stovgaard@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index ce5777fbe9..4ff751d9f0 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -148,6 +148,10 @@ do_install() {
# for v6.1+ (otherwise we are missing multiple default targets)
cp -a --parents Kbuild $kerneldir/build 2>/dev/null || :
+ # For v6.6+ the debian packing is moved out to seperate rules file
+ # Remove as we else would ned to RDEPEND on make
+ rm $kerneldir/build/scripts/package/debian/rules 2>/dev/null || :
+
# if our build dir had objtool, it will also be rebuilt on target, so
# we copy what is required for that build
if [ -f ${B}/tools/objtool/objtool ]; then