summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-08-21 11:44:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-22 15:13:51 +0100
commit92642acd1166b7990fb520337b78a4d37ce7cbe4 (patch)
tree10a67b41939cf31ad31998ed4244845e9a76ee9d
parentf9fc16e1776452d3f0c4d6dd8f8eece66722128a (diff)
downloadopenembedded-core-contrib-92642acd1166b7990fb520337b78a4d37ce7cbe4.tar.gz
linux-yocto/6.1: fix uninitialized read in nohz_full/isolcpus setup
Integrating the following commit(s) to linux-yocto/6.1: 4675ec8d0b9a kernel/sched: Fix uninitialized read in nohz_full/isolcpus setup The carry forward of commit from the v5.15 linux-yocto kernel: https://git.yoctoproject.org/linux-yocto/commit/?id=97c96388922 ...in which case the sanity checks are properly *after* the allocation and processing of the bootargs into the cpumask. However, it seems patch (or wiggle?) apparently decided to put the sanity checks *before* the population of the cpumask during the carry-forward and generation of the new v6.1 kernel. Meaning they are validating uninitialized memory and hence nohz_full= and isolcpus= are subject to random failures even for valid input ranges. (From OE-Core rev: 4b349ee66eab8ebe3150ac4c1b449ea5c264a5be) Signed-off-by: Adrian Cinal <adriancinal1@gmail.com> Acked-by: Paul Gortmaker <paul.gortmaker@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.1.bb24
3 files changed, 16 insertions, 16 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
index 8e59cf937e..7b410df847 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.1.bb
@@ -14,8 +14,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "0aa0b7396b5cbfccd69d23b07e095e4c4fa20589"
-SRCREV_meta ?= "8da434f09dc2892d8ec26325f0856aabccc17bed"
+SRCREV_machine ?= "57eb889d204238845f238b44db6affe64480b958"
+SRCREV_meta ?= "2e1a81f17434de2a9bd27676efdde7861946582e"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
index c0c93fd3da..a37da27401 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.1.bb
@@ -17,8 +17,8 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_meta ?= "8da434f09dc2892d8ec26325f0856aabccc17bed"
+SRCREV_machine ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_meta ?= "2e1a81f17434de2a9bd27676efdde7861946582e"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.1.bb b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
index ce782677c5..a54e98ee92 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
@@ -18,18 +18,18 @@ KBRANCH:qemux86-64 ?= "v6.1/standard/base"
KBRANCH:qemuloongarch64 ?= "v6.1/standard/base"
KBRANCH:qemumips64 ?= "v6.1/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "f009f4217b1b00e7de4fde7454a86ff5cc83ceef"
-SRCREV_machine:qemuarm64 ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_machine:qemuloongarch64 ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_machine:qemumips ?= "3db59f99ef5fddd5dc436d0e58bb9572051e08ed"
-SRCREV_machine:qemuppc ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_machine:qemuriscv64 ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_machine:qemuriscv32 ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_machine:qemux86 ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_machine:qemux86-64 ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_machine:qemumips64 ?= "173a48cfd962bf386bc591f1bb654d88d70cde6c"
-SRCREV_machine ?= "fb0e7ef6dd4b51325abcaab53645962994018135"
-SRCREV_meta ?= "8da434f09dc2892d8ec26325f0856aabccc17bed"
+SRCREV_machine:qemuarm ?= "df11584ee46919ffa45c33ba496754db47c59b66"
+SRCREV_machine:qemuarm64 ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_machine:qemuloongarch64 ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_machine:qemumips ?= "5d4417bb0ff0d6c89e41a694e20135e1dce778f3"
+SRCREV_machine:qemuppc ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_machine:qemuriscv64 ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_machine:qemuriscv32 ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_machine:qemux86 ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_machine:qemux86-64 ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_machine:qemumips64 ?= "c2a60bb7b1739180481e1d7a7e87bb573aa01ae7"
+SRCREV_machine ?= "786775632028f7909d9f905c4530d7eaae0b2ab0"
+SRCREV_meta ?= "2e1a81f17434de2a9bd27676efdde7861946582e"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll
# get the <version>/base branch, which is pure upstream -stable, and the same