summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-15 18:00:37 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-16 07:40:30 +0100
commit0b1e3746478e9ad1800b027ab5dc96495997807e (patch)
tree9bfb0cb23b8f5deb7ecdc50a11f9e48aca2e925c
parentaa8fd5e7c2a1125895accfd55ce9320819a10959 (diff)
downloadopenembedded-core-contrib-0b1e3746478e9ad1800b027ab5dc96495997807e.tar.gz
curl: Fix determinism issues in ptest package
NROFF can take different values depending on the filesystem layout of the host system and this leaks onto the target ptest package through the Makefiles. Since ptest doesn't use them, delete them to resovle that issue. Also ensure the task can rerun even if it already deleted configurehelp.pm [YOCTO #14863] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/curl/curl_7.84.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl_7.84.0.bb b/meta/recipes-support/curl/curl_7.84.0.bb
index 28b09ef017..75417cd1bc 100644
--- a/meta/recipes-support/curl/curl_7.84.0.bb
+++ b/meta/recipes-support/curl/curl_7.84.0.bb
@@ -93,9 +93,10 @@ do_compile_ptest() {
do_install_ptest() {
cat ${WORKDIR}/disable-tests >> ${S}/tests/data/DISABLED
- rm ${B}/tests/configurehelp.pm
+ rm -f ${B}/tests/configurehelp.pm
cp -rf ${B}/tests ${D}${PTEST_PATH}
cp -rf ${S}/tests ${D}${PTEST_PATH}
+ find ${D}${PTEST_PATH}/ -type f -name Makefile.am -o -name Makefile.in -o -name Makefile -delete
install -d ${D}${PTEST_PATH}/src
ln -sf ${bindir}/curl ${D}${PTEST_PATH}/src/curl
cp -rf ${D}${bindir}/curl-config ${D}${PTEST_PATH}