summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-08-21 11:44:45 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-22 15:13:51 +0100
commit75ca8527bb90c98b7139ad92e4e5f1baf790e75d (patch)
tree01491c60768439088144bd713e3d3d0f4657866a
parent2099b728c48d920aa3914f4297563105a672e174 (diff)
downloadopenembedded-core-contrib-75ca8527bb90c98b7139ad92e4e5f1baf790e75d.tar.gz
linux-yocto/6.4: fix IRQ-80 warnings
Integrating the following commit(s) to linux-yocto/6.4: 9753b4497951 tick/rcu: fix false positive "softirq work is pending" messages on RT Paul Gortmaker has found and fixed the root cause of why we are getting "softirq work is pending" messages on boot with -rt .. although the issue is not rt-specific. The fix has been submitted to lkml, but we are integrating it to avoid the delay of -stable picking it up and then linux-yocto doing the same. (From OE-Core rev: 5617d2c03833830c0100d1c775a15d4ad1c02fdd) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.4.bb22
3 files changed, 13 insertions, 13 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
index 95891cdf60..5f633405ea 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_6.4.bb
@@ -14,7 +14,7 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "efba76521c3c18fc10ab88e3b94293f19be9fdc8"
+SRCREV_machine ?= "7b9505550d7a84a1f30b9af8b90aafc8dde37023"
SRCREV_meta ?= "d9483a24c9ee33b6e566baa5233cbd9feaeb5212"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine;protocol=https \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
index 5de53abcd2..982352b010 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_6.4.bb
@@ -17,7 +17,7 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
+SRCREV_machine ?= "9753b4497951a5bd1a921e784532257d26a8b008"
SRCREV_meta ?= "d9483a24c9ee33b6e566baa5233cbd9feaeb5212"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.4.bb b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
index 45d19edb79..ce406db90e 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.4.bb
@@ -18,17 +18,17 @@ KBRANCH:qemux86-64 ?= "v6.4/standard/base"
KBRANCH:qemuloongarch64 ?= "v6.4/standard/base"
KBRANCH:qemumips64 ?= "v6.4/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "1918d171c09ab3aeedcf7c9f0a98d7c3c10a8524"
-SRCREV_machine:qemuarm64 ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
-SRCREV_machine:qemuloongarch64 ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
-SRCREV_machine:qemumips ?= "f3ec8aee3f7ce0adc65668dd18347f144c12709c"
-SRCREV_machine:qemuppc ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
-SRCREV_machine:qemuriscv64 ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
-SRCREV_machine:qemuriscv32 ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
-SRCREV_machine:qemux86 ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
-SRCREV_machine:qemux86-64 ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
-SRCREV_machine:qemumips64 ?= "bc7632d06c742e712514981591ce647b5d6cbd15"
-SRCREV_machine ?= "e28e14070ba4eba3b6832a8329d4120ed5de8efa"
+SRCREV_machine:qemuarm ?= "d4dbcad8e827ce8e71a29b69acc19f4d3f689119"
+SRCREV_machine:qemuarm64 ?= "9753b4497951a5bd1a921e784532257d26a8b008"
+SRCREV_machine:qemuloongarch64 ?= "9753b4497951a5bd1a921e784532257d26a8b008"
+SRCREV_machine:qemumips ?= "3bab6247ffb07f9de6bdb388854461d0ab7bc7dd"
+SRCREV_machine:qemuppc ?= "9753b4497951a5bd1a921e784532257d26a8b008"
+SRCREV_machine:qemuriscv64 ?= "9753b4497951a5bd1a921e784532257d26a8b008"
+SRCREV_machine:qemuriscv32 ?= "9753b4497951a5bd1a921e784532257d26a8b008"
+SRCREV_machine:qemux86 ?= "9753b4497951a5bd1a921e784532257d26a8b008"
+SRCREV_machine:qemux86-64 ?= "9753b4497951a5bd1a921e784532257d26a8b008"
+SRCREV_machine:qemumips64 ?= "de0569e0860973391d16074bbe9366afb15594bf"
+SRCREV_machine ?= "9753b4497951a5bd1a921e784532257d26a8b008"
SRCREV_meta ?= "d9483a24c9ee33b6e566baa5233cbd9feaeb5212"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll