aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-11-28 14:17:21 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-30 15:03:41 +0000
commitb4fc41a85d088c60c6f687f2354fe9ca27b46e8e (patch)
treeced8474310f02fee821cbdb27ce4406537e1c523
parentba6a06c864571cd6ee6b68bfda51dfdda70cbc7d (diff)
downloadopenembedded-core-contrib-b4fc41a85d088c60c6f687f2354fe9ca27b46e8e.tar.gz
ocf-linux: Add ocf-linux to support openssl 1.0
Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-connectivity/openssl/ocf-linux.inc25
-rw-r--r--meta/recipes-connectivity/openssl/ocf-linux_20100325.bb6
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/ocf-linux.inc b/meta/recipes-connectivity/openssl/ocf-linux.inc
new file mode 100644
index 0000000000..f4ec7c99c5
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/ocf-linux.inc
@@ -0,0 +1,25 @@
+DESCRIPTION = "Install required headers to enable OCF Linux support"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://README;md5=b02a793c9b7893b4ce1f39f0b231ccd7"
+
+INC_PR = "r3"
+
+SRC_URI = "http://sourceforge.net/projects/ocf-linux/files/ocf-linux/${PV}/ocf-linux-${PV}.tar.gz"
+
+S = "${WORKDIR}/ocf-linux-${PV}"
+
+# Need to unpack the the ocf-linux.tar.gz file contained inside the
+# downloaded tarball
+# Install the OCF Linux headers so that other packages such as openssl
+# can find them. The headers must be in a crypto directory according to
+# the README file.
+do_install() {
+ cd ${S}
+ tar xzf ocf-linux.tar.gz
+ install -d ${D}${includedir}/crypto
+ install -m 0644 ${S}/ocf/*.h ${D}${includedir}/crypto/
+}
+
+ALLOW_EMPTY = "1"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-connectivity/openssl/ocf-linux_20100325.bb b/meta/recipes-connectivity/openssl/ocf-linux_20100325.bb
new file mode 100644
index 0000000000..9dccc3c32f
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/ocf-linux_20100325.bb
@@ -0,0 +1,6 @@
+require ocf-linux.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI[md5sum] = "ce5ad54aa94226d496df1f0f3cf0c11f"
+SRC_URI[sha256sum] = "9d17cbd13849939c70699b520280e3b94cf77401cdc131108d4aeaaeea587f6b"