summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-11-07 12:50:14 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-08 22:01:53 +0000
commita31fbec45d24df5b74091940d0e0b2daf34d8492 (patch)
tree4d2d6c400b21de199257abb3b63eccb52259e1b6
parentb0f30792fd0ea41f1d1590dbe0452c956e018c82 (diff)
downloadopenembedded-core-contrib-a31fbec45d24df5b74091940d0e0b2daf34d8492.tar.gz
wayland: Fix wayland-tools packaging
There are some packaging problems due to the wayland-tools packaging implementation. The wayland-tools package currently looks like this: wayland-tools └── usr ├── bin │   └── wayland-scanner └── share └── wayland ├── wayland.dtd ├── wayland-scanner.mk └── wayland.xml The files wayland.dtd and wayland.xml belong in the main package, while wayland-scanner.mk belongs in wayland-dev. Fix the wayland.dtd and wayland.xml packaging by prepending the wayland-tools package and dropping the main package FILES variable override. The file wayland-scanner.mk is included in the main package by default, and so must be explicitly added to wayland-dev. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/wayland/wayland_1.19.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/wayland/wayland_1.19.0.bb b/meta/recipes-graphics/wayland/wayland_1.19.0.bb
index d6e468497d..5f8b972f76 100644
--- a/meta/recipes-graphics/wayland/wayland_1.19.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.19.0.bb
@@ -52,10 +52,10 @@ sysroot_stage_all:append:class-target () {
cp ${STAGING_DATADIR_NATIVE}/aclocal/wayland-scanner.m4 ${SYSROOT_DESTDIR}/${datadir}/aclocal/
}
-PACKAGES += "${PN}-tools"
+PACKAGES =+ "${PN}-tools"
-FILES:${PN} = "${libdir}/*${SOLIBS}"
-FILES:${PN}-tools += "${bindir} ${datadir}/wayland"
+FILES:${PN}-tools = "${bindir}/wayland-scanner"
+FILES:${PN}-dev += "${datadir}/${BPN}/wayland-scanner.mk"
BBCLASSEXTEND = "native nativesdk"