summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-06-06 14:01:26 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-07 21:11:57 +0100
commit6422e62fbc5c65a2165a72c97c880cfa9a80e957 (patch)
tree4fa14afa89770cc261a13c81f9c02503274700df
parent00aeb84a5e7c6d4293fb4cd30dd1e28d60c6aac5 (diff)
downloadopenembedded-core-contrib-6422e62fbc5c65a2165a72c97c880cfa9a80e957.tar.gz
perl: enable _GNU_SOURCE define via d_gnulibc
This is needed to properly support memmem() and friends under musl as musl guards the declarations with _GNU_SOURCE define, and if the declarations are not present, gcc will issue warnings and generate assembly that assumes the functions return int (instead of e.g. void*), with catastrophic consequences at runtime. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.36.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.36.0.bb b/meta/recipes-devtools/perl/perl_5.36.0.bb
index 05668bc966..4456cdbcfb 100644
--- a/meta/recipes-devtools/perl/perl_5.36.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.36.0.bb
@@ -61,6 +61,7 @@ do_configure:class-target() {
-Dlibpth='${libdir} ${base_libdir}' \
-Dglibpth='${libdir} ${base_libdir}' \
-Alddlflags=' ${LDFLAGS}' \
+ -Dd_gnulibc=define \
${PACKAGECONFIG_CONFARGS}
#perl.c uses an ARCHLIB_EXP define to generate compile-time code that