summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2022-06-09 15:03:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-11 10:28:12 +0100
commit4cf536b44a6f3fdd5f31e5ddb91184bce05651b9 (patch)
tree97a32b8bf945aff67b4caad47a4a8a8bebd01150
parenta45d9dc089fb2719ca69b92870917f8c0925f632 (diff)
downloadopenembedded-core-contrib-4cf536b44a6f3fdd5f31e5ddb91184bce05651b9.tar.gz
systemd: Fix build without utmp
* backport the fix for regression in v251.2 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/systemd/systemd/0001-shared-utmp-wtmp-fix-build-without-utmp.patch32
-rw-r--r--meta/recipes-core/systemd/systemd_251.2.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd/0001-shared-utmp-wtmp-fix-build-without-utmp.patch b/meta/recipes-core/systemd/systemd/0001-shared-utmp-wtmp-fix-build-without-utmp.patch
new file mode 100644
index 0000000000..2bb9565bf2
--- /dev/null
+++ b/meta/recipes-core/systemd/systemd/0001-shared-utmp-wtmp-fix-build-without-utmp.patch
@@ -0,0 +1,32 @@
+From d6e2c2d34d336398f5948a8b731fefff3dc0ff12 Mon Sep 17 00:00:00 2001
+From: Christian Hesse <mail@eworm.de>
+Date: Thu, 2 Jun 2022 20:49:46 +0200
+Subject: [PATCH] shared/utmp-wtmp: fix build without utmp
+
+Commit 16618332388442f2f1c3e52b0a9fde00121564a3 changed a function to
+add an extra argument. The data types used when building without utmp
+missed the change.
+
+Upstream-Status: Backport [d6e2c2d34d336398f5948a8b731fefff3dc0ff12]
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+---
+ src/shared/utmp-wtmp.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/shared/utmp-wtmp.h b/src/shared/utmp-wtmp.h
+index 36e4203b4f..188d011fdd 100644
+--- a/src/shared/utmp-wtmp.h
++++ b/src/shared/utmp-wtmp.h
+@@ -59,7 +59,7 @@ static inline int utmp_wall(
+ const char *message,
+ const char *username,
+ const char *origin_tty,
+- bool (*match_tty)(const char *tty, void *userdata),
++ bool (*match_tty)(const char *tty, bool is_local, void *userdata),
+ void *userdata) {
+ return 0;
+ }
+--
+2.36.1
+
diff --git a/meta/recipes-core/systemd/systemd_251.2.bb b/meta/recipes-core/systemd/systemd_251.2.bb
index 80f80849d0..8370bec0ca 100644
--- a/meta/recipes-core/systemd/systemd_251.2.bb
+++ b/meta/recipes-core/systemd/systemd_251.2.bb
@@ -24,6 +24,7 @@ SRC_URI += "file://touchscreen.rules \
file://0001-binfmt-Don-t-install-dependency-links-at-install-tim.patch \
file://0003-implment-systemd-sysv-install-for-OE.patch \
file://0001-Move-sysusers.d-sysctl.d-binfmt.d-modules-load.d-to-.patch \
+ file://0001-shared-utmp-wtmp-fix-build-without-utmp.patch \
"
# patches needed by musl