summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-20 13:09:52 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-21 17:46:46 +0000
commitaa56c5dcdea152bee62bb480ccaae177f6c69b9b (patch)
tree6b75e3bed20ddd30cf78fd679dee7aee0f28cf1b
parentdcd1fbe153369634c73370cbe22e1dbdac080146 (diff)
downloadopenembedded-core-contrib-aa56c5dcdea152bee62bb480ccaae177f6c69b9b.tar.gz
dnf, libdnf: Ignore if PACKAGE_CLASSES does not have rpm
dnf depends on libsolv, and libsolv does not have and easy way to jusr enable rpmdb support, it either has full rpm or nothing, perhaps it could be improved in libsolv and we can use that but from now we have no other option dnf support only rpm backend and wont work with opkg or dpkg/apt anyway Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/dnf/dnf_4.2.2.bb2
-rw-r--r--meta/recipes-devtools/libdnf/libdnf_0.28.1.bb1
2 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_4.2.2.bb b/meta/recipes-devtools/dnf/dnf_4.2.2.bb
index f38167f1ad..f6e616e7f1 100644
--- a/meta/recipes-devtools/dnf/dnf_4.2.2.bb
+++ b/meta/recipes-devtools/dnf/dnf_4.2.2.bb
@@ -84,3 +84,5 @@ SYSTEMD_SERVICE_${PN} = "dnf-makecache.service dnf-makecache.timer \
dnf-automatic-notifyonly.service dnf-automatic-notifyonly.timer \
"
SYSTEMD_AUTO_ENABLE ?= "disable"
+
+PNBLACKLIST[dnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"
diff --git a/meta/recipes-devtools/libdnf/libdnf_0.28.1.bb b/meta/recipes-devtools/libdnf/libdnf_0.28.1.bb
index 882c435b32..d498347094 100644
--- a/meta/recipes-devtools/libdnf/libdnf_0.28.1.bb
+++ b/meta/recipes-devtools/libdnf/libdnf_0.28.1.bb
@@ -26,4 +26,5 @@ EXTRA_OECMAKE_append_class-native = " -DWITH_GIR=OFF"
EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_GIR=OFF"
BBCLASSEXTEND = "native nativesdk"
+PNBLACKLIST[libdnf] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'Does not build without package_rpm in PACKAGE_CLASSES due disabled rpm support in libsolv', d)}"