aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-03-23 05:50:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-23 14:00:43 +0000
commitd56177c59b5e237a501281d806724885456f0193 (patch)
tree9b3b8637a30bb5ac84ec7d33bca64a2f2ae94fcd
parent5de06b564a949d0d9ec254817feacf9ad18d098c (diff)
downloadopenembedded-core-contrib-d56177c59b5e237a501281d806724885456f0193.tar.gz
gdb-cross-canadian: Fix linking issues when python support is enabled
gdb-cross-canadian was linking with static version of libpython and looking for build host python when run. This could be mismatch between python-nativesdk and build host provided python. So we make it consistent to always use python-nativesdk Instead of adding bunch of -L we add -rpath and -rpath-link so that gdb finds all needed libraries in SDK and does not reach out into host This should fix yocto PR# 2077 as well. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/gdb/gdb-cross-canadian.inc7
-rw-r--r--meta/recipes-devtools/gdb/gdb-cross-canadian_7.4.bb2
2 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-devtools/gdb/gdb-cross-canadian.inc b/meta/recipes-devtools/gdb/gdb-cross-canadian.inc
index 47d7d28a2b..2b6069883e 100644
--- a/meta/recipes-devtools/gdb/gdb-cross-canadian.inc
+++ b/meta/recipes-devtools/gdb/gdb-cross-canadian.inc
@@ -1,4 +1,5 @@
inherit cross-canadian
+inherit python-dir
DESCRIPTION = "cross-canadian gdb for ${TARGET_ARCH} target - GNU debugger"
PN = "gdb-cross-canadian-${TRANSLATED_TARGET_ARCH}"
@@ -14,9 +15,9 @@ do_configure_prepend() {
cat > ${WORKDIR}/python << EOF
#! /bin/sh
case "\$2" in
- --includes) echo "-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}/" ;;
- --ldflags) echo "-L${STAGING_LIBDIR}/../python${PYTHON_BASEVERSION}/config -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
- --exec-prefix) echo "/usr" ;;
+ --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
+ --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
+ --exec-prefix) echo "${exec_prefix}/bin" ;;
*) exit 1 ;;
esac
exit 0
diff --git a/meta/recipes-devtools/gdb/gdb-cross-canadian_7.4.bb b/meta/recipes-devtools/gdb/gdb-cross-canadian_7.4.bb
index dfb7d8122a..8e68c75782 100644
--- a/meta/recipes-devtools/gdb/gdb-cross-canadian_7.4.bb
+++ b/meta/recipes-devtools/gdb/gdb-cross-canadian_7.4.bb
@@ -1,7 +1,7 @@
require gdb-common.inc
require gdb-cross-canadian.inc
-PR = "${INC_PR}.4"
+PR = "${INC_PR}.5"
GDBPROPREFIX = "--program-prefix='${TARGET_PREFIX}'"
EXPAT = "--with-expat"